How config vlan on TP-Link C6 v2

I have this config:
if on vlan 11 then only works if vlan 11 interface stopped same applies to all the others
none of the address can ping other vlan 1

Would like vlan 1 untagged, 10-15 tagged and 99 ( not present yet)

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd81:a475:9d60::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        option bridge_empty '1'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10'
        list ports 'eth0.11'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ip6assign '60'
        option ipaddr '192.168.4.4'
        option netmask '255.255.252.0'
        option gateway '192.168.4.1'
        option delegate '0'
        list dns '192.168.5.5'
        list dns '192.168.5.6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option ports '2t 3t 4t 5t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '11'
        option ports '2t 3t 4t 5t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '12'
        option ports '2t 3t 4t 5t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '13'
        option ports '2t 3t 4t 5t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '14'
        option ports '2t 3t 4t 5t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '15'
        option ports '2t 3t 4t 5t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config device
        option name 'eth0'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'eth0:u*'
        list ports 'eth0.1:u*'
        list ports 'eth0.2:u*'
        list ports 'eth0.10:t'
        list ports 'eth0.11:t'
        list ports 'eth0.12:t'
        list ports 'eth0.13:t'
        list ports 'eth0.14:t'
        list ports 'eth0.15:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10:t'
        list ports 'eth0.11'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config bridge-vlan
        option device 'br-lan'
        option vlan '11'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10'
        list ports 'eth0.11:t'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config bridge-vlan
        option device 'br-lan'
        option vlan '12'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10'
        list ports 'eth0.11'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config bridge-vlan
        option device 'br-lan'
        option vlan '13'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10'
        list ports 'eth0.11'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config bridge-vlan
        option device 'br-lan'
        option vlan '14'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10'
        list ports 'eth0.11'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config bridge-vlan
        option device 'br-lan'
        option vlan '15'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        list ports 'eth0.10'
        list ports 'eth0.11'
        list ports 'eth0.12'
        list ports 'eth0.13'
        list ports 'eth0.14'
        list ports 'eth0.15'

config interface 'vlan10L'
        option proto 'static'
        option device 'br-lan.10'
        option ipaddr '192.168.10.4'
        option netmask '255.255.255.0'

config interface 'vlan11W'
        option proto 'static'
        option device 'br-lan.11'
        option ipaddr '192.168.11.4'
        option netmask '255.255.255.0'

config interface 'vlan12P'
        option proto 'static'
        option device 'br-lan.12'
        option ipaddr '192.168.12.4'
        option netmask '255.255.255.0'

config interface 'vlan13I'
        option proto 'static'
        option device 'br-lan.13'
        option ipaddr '192.168.13.4'
        option netmask '255.255.255.0'

config interface 'vlan14O'
        option proto 'static'
        option device 'br-lan.14'
        option ipaddr '192.168.14.4'
        option netmask '255.255.255.0'

config interface 'vlan15V'
        option proto 'static'
        option device 'br-lan.15'
        option ipaddr '192.168.15.4'
        option netmask '255.255.255.0'

You seem to be mixing DSA and swconfig syntax, which doesn't really work that way.

(as I don't see information about the archer c2 v2, I can't comment beyond that).

stock config on TP-link C6 before changes

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd23:89e3:39a3::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        option ipaddr '192.168.4.5'
        option netmask '255.255.252.0'
        option gateway '192.168.4.1'
        option delegate '0'
        option dns '192.168.5.5 192.168.5.6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config device
        option name 'eth0'

config device
        option name 'eth0.1'
        option type '8021q'
        option ifname 'eth0'
        option vid '1'

config device
        option name 'eth0.2'
        option type '8021q'
        option ifname 'eth0'
        option vid '2'

Hi

if this is a "swconfig" device then this is wrong

eth0 is a switch port facing to CPU
so it could not be included or used in any bridge
remove it first

but, as @slh stated, whole config is a mess of DSA/swconfig mix

best way is to reset to factory default
then paste the default config here

stock config

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd23:89e3:39a3::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth0.2'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        option ipaddr '192.168.4.5'
        option netmask '255.255.252.0'
        option gateway '192.168.4.1'
        option delegate '0'
        option dns '192.168.5.5 192.168.5.6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config device
        option name 'eth0'

config device
        option name 'eth0.1'
        option type '8021q'
        option ifname 'eth0'
        option vid '1'

config device
        option name 'eth0.2'
        option type '8021q'
        option ifname 'eth0'
        option vid '2'

it could NOT be stock config !!!!

1 Like

Yes IP, netmask, and gateway are changed.
no others setting

please, if you want to someone help, then, please, reset the router to factory
and then paste config

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3c:60a3:b9c0::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

What port(s) does this apply to? All? One?
Do you need wireless for each of these VLANs (on the C6)?

To put VLAN 10 on logical port 2 as a tagged network, you do this:

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vlan '10'
        option ports '2t 0t'

Then create a bridge for VLAN 10 (only necessary if you are going to attach it to wifi):

config device
        option name 'br-vlan10'
        option type 'bridge'
        list ports 'eth0.10'

And then create a network using the bridge defined earlier (if you don't use need wifi, you can directly tie this to eth0.10 instead of br-vlan10):

config interface 'vlan10'
        option device 'br-vlan10'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'

Rinse and repeat for the others. Don't forget to assign the new networks to a firewall zone (start by just assigning them to the lan zone, then once proven working you can tighten it up if desired). In most cases, you'll also want to setup a DHCP server for each network.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.