Hi Community!
I'm using LuCI openwrt-23.05 branch (git-24.086.45142-09d5a38) / OpenWrt 23.05.4 (r24012-d8dd03c46f) and I cannot update lists of the available software.
With the Google Home app, I can configure the Google Chromecast 3. Geneneration and, in particular, allow Wi-Fi access, but I cannot add the Google Chromecast as a device in the Google Home app because the Google Chromecast could not be found.
The smartphone and the Google Chromecast are in the same Wi-Fi network and in the same subnet.
How is it possible for me to use the Google Chromecast 3. Generation with OpenWrt, in particular to add it as a device via the Google Home app?
Thanks for your assistance!
You say you use the same wifi, but I recently noticed you have to be on the same SSID as the Google device, for it to be found, when adding.
Can't blame Openwrt for it though.
1 Like
This normally has nothing to do with OpenWrt, it let’s take a look at your config to make sure you don’t have something that would specifically cause issues.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
The router will tell you ?
1 Like
root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.162",
"hostname": "OpenWrt",
"system": "ARMv7 Processor rev 5 (v7l)",
"model": "AVM FRITZ!Box 4040",
"board_name": "avm,fritzbox-4040",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.4",
"revision": "r24012-d8dd03c46f",
"target": "ipq40xx/generic",
"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
}
}
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd56:9ae4:2114::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
option ipv6 '0'
option igmp_snooping '1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.100.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
option peerdns '0'
list dns '10.2.0.1'
config interface 'wan6'
option device 'wan'
option proto 'static'
option ipaddr '192.168.150.1'
list dns '10.2.0.1'
config interface 'wlan2G'
option proto 'static'
option device 'phy0-ap0'
option ipaddr '192.168.170.1'
option netmask '255.255.255.0'
config device
option name 'wan'
option ipv6 '0'
config device
option name 'phy0-ap0'
option ipv6 '0'
config interface 'wlanGast2G'
option proto 'static'
option ipaddr '192.168.160.1'
option netmask '255.255.255.0'
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/a000000.wifi'
option channel 'auto'
option band '2g'
option htmode 'HT20'
option cell_density '0'
option country 'DE'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/a800000.wifi'
option channel 'auto'
option band '5g'
option htmode 'HT20'
option cell_density '0'
option country 'DE'
config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'XXXXXXXXXX'
option encryption 'sae-mixed'
option key 'XXXXXXXXXX'
option network 'wlan2G'
option isolate '1'
option disassoc_low_ack '0'
config wifi-iface 'wifinet2'
option device 'radio0'
option mode 'ap'
option ssid 'XXXXXXXXXXX'
option encryption 'sae-mixed'
option key 'XXXXXXXXXXX'
option network 'wlanGast2G'
option disassoc_low_ack '0'
root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
option confdir '/tmp/dnsmasq.d'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
option start '100'
option limit '150'
option leasetime '12h'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'wlan2G'
option interface 'wlan2G'
option start '2'
option limit '10'
option leasetime '12h'
config host
option name 'XXXXXXXXXX'
option ip '192.168.170.2'
list mac 'XXXXXXXXXX'
config host
option name 'XXXXXXXXXX'
option ip '192.168.170.5'
list mac 'XXXXXXXXXX'
config host
option name 'XXXXXXXXXX'
option ip '192.168.170.4'
list mac 'XXXXXXXXXX'
config dhcp 'wlanGast2G'
option interface 'wlanGast2G'
option start '2'
option limit '10'
option leasetime '12h'
config host
option name 'XXXXXXXXXX'
option ip '192.168.170.6'
list mac 'XXXXXXXXXX'
config host
option ip '192.168.160.6'
option name 'XXXXXXXXXX'
list mac 'XXXXXXXXXX'
config host
option name 'GoogleChromecast'
option ip '192.168.170.7'
list mac 'XXXXXXXXXX'
config host
option name 'XXXXXXXXXX'
option ip '192.168.160.3'
list mac 'XXXXXXXXXX'
config host
option name 'XXXXXXXXXX'
option ip '192.168.160.2'
list mac 'XXXXXXXXXX'
config host
option name 'XXXXXXXXXX'
option ip '192.168.170.11'
list mac 'XXXXXXXXXX'
config host
option name 'XXXXXXXXXX'
option ip '192.168.100.2'
list mac 'XXXXXXXXXX'
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'DROP'
option synflood_protect '1'
option drop_invalid '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
list device 'tun0'
list network 'wan'
list network 'wan6'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
option family 'ipv4'
config zone
option name 'wlan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'wlan2G'
config forwarding
option src 'wlan'
option dest 'wan'
config zone
option name 'wlangast'
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
list network 'wlanGast2G'
config forwarding
option src 'wlangast'
option dest 'wan'
config rule
option name 'wlan_gast_2G_dhcp'
option src 'wlangast'
option dest_port '67 68'
option target 'ACCEPT'
option family 'ipv4'
list proto 'tcp'
list proto 'udp'
config rule
option name 'wlan_gast_2G_dns'
option src 'wlangast'
option dest_port '53'
option target 'ACCEPT'
option family 'ipv4'
It's a wireless clients, so I guess where those are listed ?
Sae-mixed is a terrible choice, change it to wpa2 or wpa3, it could be the reason why discovery is failing.
2 Likes
There is a lot going on here that doesn't look right...
Remove the last 2 lines of this section:
Where is the 10.2.0.0/24 network?? I don't see it in your config... is it upstream? This is relevant for your DNS:
Why is wan6 populated with IPv4 entries?
Do you want your wlan2g network to be on a different subnet than your main lan? Also, the radio devices should never be specified in the network file... that should be removed:
This doesn't belong...
Most of the time, 40MHz width (or greater) are used for 5G. Why are you using a 20MHz channel width?
As @frollic pointed out, don't use sae-mixed. use either WPA2 or WPA3, not mixed. But more critically, you have the isolate option enabled... if this is the network that you are trying to use for your Chromecast, it will not be able to talk to any other wifi devices. Remove the isolation.
4 Likes
You say you use the same wifi, but I recently noticed you have to be on the same SSID as the Google device, for it to be found, when adding.
Yes, the smartphone with which I want to set up and connect the Google Chromecast and the Google Chromecast use the same BSSID of the WLAN controller.
Switching to WPA3 means that the Google Chromecast 3rd generation cannot find the Wi-Fi network. Switching to WPA2, on the other hand, resulted in the Google Chromecast being able to find the Wi-Fi network, but the Google Home app is still unable to connect to the Google Chromecast.
psherman:
Where is the 10.2.0.0/24 network?? I don't see it in your config... is it upstream? This is relevant for your DNS:
config interface 'wan'
option device 'wan'
option proto 'dhcp'
option peerdns '0'
list dns '10.2.0.1'
I don't know! And I don't know where I can configure this.
I personally would just edit the config file directly using the vi text editor. However, there is probably a LuCI web interface control for this in the Network > Interfaces > Devices
.
frollic
November 6, 2024, 8:50pm
15
Or, to get rid of all the issues, reset, then rename the wifi, set password and encryption, leave everything else as it is.
psherman:
As @frollic pointed out, don't use sae-mixed. use either WPA2 or WPA3, not mixed. But more critically, you have the isolate option enabled... if this is the network that you are trying to use for your Chromecast, it will not be able to talk to any other wifi devices. Remove the isolation.
config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'XXXXXXXXXX'
option encryption 'sae-mixed'
option key 'XXXXXXXXXX'
option network 'wlan2G'
option isolate '1'
option disassoc_low_ack '0'
Isolation is deactivated. The connection to the Google Chromecast with the Google Home app now works. Thank you very much for your help!
config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'XXXXXXXXXX'
option encryption 'psk2'
option key 'XXXXXXXXXX'
option network 'wlan2G'
option disassoc_low_ack '0'
glad that fixed the problem.
If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks!
system
Closed
November 16, 2024, 9:05pm
18
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.