How can I running zerotier without NAT?

Physical Network:
Subnet 1: 192.168.128.0/24
Subnet 2: 192.168.129.0/24
They are in different locations.

Zerotier Network:
Subnet: 10.0.0.0/24

Router A is 192.168.128.254, and have zerotier ip 10.0.0.1.
Router B is 192.168.129.254, and have zerotier ip 10.0.0.2.

I have configured zerotier routes:
192.168.128.0/24 10.0.0.1
192.168.129.0/24 10.0.0.2
And enable Allow Ethernet Bridging both.

For now I can ping and access subnet device for each other.

Then I have a Nginx server on 192.168.128.1.
When a client access from subnet 192.168.129.0/24, Nginx log 10.0.0.2 as client ip.

How can Nginx get origin subnet client ip address?

Network Configuration:

config interface 'vpn'
        option proto 'dhcp'
        option device 'zt2lrqfsvn'

Firewall Configuration:

config zone
        option name 'vpn'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'vpn'

config forwarding
        option src 'vpn'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'vpn'

config forwarding
        option src 'vpn'
        option dest 'wan'

Both router configuration are the same (device name is different).