How can I implement the triple play VLAN feature in the new DSA architecture?

I am using Phicomm K2P, System info:

Model: Phicomm K2P
Architecture: MediaTek MT7621 ver:1 eco:3
Target Platform: ramips/mt7621
Firmware Version: OpenWrt 22.03.0 r19685-512e76967f / LuCI openwrt-22.03 branch git-22.245.77528-487e58a
Kernel Version	5.10.138

how can I implement the triple play feature in the new DSA architecture?
like this:
https://support.dlink.com/mobile/main/mfaq.aspx?f=xn6XOkJAoSjIPSu%2B4dTrYw%3D%3D

For example, my interface is like this,

root@OpenWrt:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.747d24923b91       no              lan1
                                                        lan2
                                                        lan3
                                                        lan4

root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd46:4b61:6d93::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.30.1'
        option device 'br-lan'

config interface 'wan'
        option proto 'dhcp'
        option device 'wan'


my broadband operator provides IPTV through vlan 36 and Internet through vlan 2502.
My TV box is connected to lan port 1 of the router (it needs to be bridged to the wan port), and the PC is connected to several other lan ports.

How do I configure /etc/config/network, so that vlan 36 and vlan 2502 can work on the wan port at the same time?

If anyone has configured trpile play, please help me, thanks!

I never tried this before but I believe for the wan side

You can either use eth0.<internet vlan> as pppoe or whatever you use, for the iptv you can set it up as dhcp client also like eth0.<tv id>.

Edit: optionally you can also try with a alias if it doesn't work but I believe thats only if you have no vlan ids on the wan side and u need to specify different protocols, then it would be something like @eth0 and then the specified protocol.

Maybe you already had it like this, then I would think of creating a bridge which covers the port you want, and the eth0.<iptv id> device, and then create a vlan bridge, tagged the iptv, and untagged your lan.

To make it easier: if u sent multiple vlans its always tagged, and the default one should be untagged.

And then check what it does if u play a little with changing the device to br-iptv alone or with br-iptv.<iptv vlan>

I think its something like this

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'br-iptv'
        option type 'bridge'
        list ports 'lan1'
        list ports 'wan.36'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.30.1'
        option device 'br-lan'

config interface 'wan'
        option proto 'dhcp'
        option device 'wan.2502'

config interface 'iptv'
        option device 'br-iptv'
        option proto 'none'

Great, it works.

For me,

config device
        ...
        list ports 'wan.36'

config interface 'iptv'
        option device 'br-iptv'
        option proto 'none'

this method is very interesting, very good!

Thanks to everyone

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.