How can I disable main ssid?

Hi everyone,

Currently, I have a problem which related to enabling/disabling the main ssid when using OpenWrt. For guest ssid, I can enable/disable normally. But when I disabled the main ssid, the guest ssid also is disabled. It seems to disabled all radio.

{code}
config wifi-device 'radio0'
option type 'bcmwifi'
option ifname 'wl0'
option country 'DE'
option channel 'auto'
option hwmode '11a'
option htmode 'HE80'
option path '/sys/devices/platform/80040000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option macaddr '00:90:4c:2d:30:03'
option txpower '100'
option beacon_int '100'
option mu_mimo '1'
option txbf '1'
option disabled '0'
option use_obss_dyn_bw '1'
option bandsteering_debug '0'
option cwmp_radio_instance '1'
option easymesh '0'
option bandsteering '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ifname 'wl0'
option ssid 'Multiplay_3001'
option encryption 'sae-mixed'
option wps_pushbutton '1'
option wmm '1'
option wmm_no_ack '0'
option wmm_apsd '1'
option wmm_ac_ap_be_ecwmin '4'
option wmm_ac_ap_be_ecwmax '6'
option wmm_ac_ap_be_aifsn '3'
option wmm_ac_ap_be_txop '0'
option wmm_ac_ap_be_acm '0'
option wmm_ac_ap_be_dp '0'
option wmm_ac_ap_bk_ecwmin '4'
option wmm_ac_ap_bk_ecwmax '10'
option wmm_ac_ap_bk_aifsn '7'
option wmm_ac_ap_bk_txop '0'
option wmm_ac_ap_bk_acm '0'
option wmm_ac_ap_bk_dp '0'
option wmm_ac_ap_vo_ecwmin '2'
option wmm_ac_ap_vo_ecwmax '3'
option wmm_ac_ap_vo_aifsn '1'
option wmm_ac_ap_vo_txop '47'
option wmm_ac_ap_vo_acm '0'
option wmm_ac_ap_vo_dp '0'
option wmm_ac_ap_vi_ecwmin '3'
option wmm_ac_ap_vi_ecwmax '4'
option wmm_ac_ap_vi_aifsn '1'
option wmm_ac_ap_vi_txop '94'
option wmm_ac_ap_vi_acm '0'
option wmm_ac_ap_vi_dp '0'
option wmf '1'
option easymesh_fh '1'
option cwmp_ssid_instance '1'
option cwmp_access_pt_instance '1'
option key 'hoangnam12345'
option isolate '0'
option hidden '0'
option disabled '0'

config wifi-iface 'guest_radio0_1'
option device 'radio0'
option network 'lan'
option wps_pushbutton '0'
option guestwifi '1'
option hidden '0'
option mode 'ap'
option ifname 'wl0.2'
option cwmp_ssid_instance '3'
option cwmp_access_pt_instance '3'
option ssid 'OpenWrt_5g_namhd'
option key 'hoangnam12345'
option encryption 'psk2'
option wmm '1'
option wmf '1'
option disabled '1'
{code}

After setting disabled option in 'default_radio0', the wl0 and wl0.2 interface are remove from brctl and ifconfig.
Please share me your idea about this problem. Thank you so much.

Is this vanilla OpenWrt? It likely is a bug in the "bcmwifi" wireless configration backend, indicating a proprietary driver.

This OpenWRT platform is based on Broadcom wifi chipsets. So this is reason why type is bcmwifi

Try changing the ifname to wl0_2

what's the output of the ubus call system board command ?

1 Like

wl0.2 is guest ssid. It works normally about enable/disable. I mean that default_radio0 is main ssid. When I set to disabled it then guest ssid also disabled. My expectation is that they should be independent.

Is there any problem with just trying what was suggested?

By using the ifname option, you set the physical interface name.
In Linux, a dot (.) is used to define a VLAN subinterface.
It seems logical that the subinterface should go down when you stop the main interface.

I tried your solution but have not changed. it may be not rootcause because all interfaces based on Broadcom chipsets used a dot for subinterface.

~ # ubus call system board
{
"kernel": "4.1.52",
"hostname": "Quantum-xxxxx",
"model": "XXXXX",
"board_name": "Broadcom-v8A",
"release": {
"distribution": "OpenWrt",
"version": "19.07.6",
"revision": "r11278-8055e38794",
"target": "brcm68xx/cortexa53",
"description": "3.1.23"
},
"gponsn": "XXXX4c2d3001",
"buildtime": "2023-11-30 09:52:23"
}
~ #

this is here

that's not openwrt, but Broadcom's derivative.


It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

3 Likes

The bug is in the bcmwifi config backend. We don't have access to it's sources, nor is it developed or supported by OpenWrt. We will not be able to help with it.

1 Like

This topic was automatically closed after 24 hours. New replies are no longer allowed.