How can I disable auto login on laptop?

I installed ImmortalWrt(based on OpenWrt 18.6) compiled by SuLingGG on a USB drive and booted from USB on Miix 510-12IKB. When I pressed "Enter", root user was logged in without requiring password. I think it is very insecure to log in without entering password. How can I disable auto login and use password to log in.

Your post does not appear to be related to an officially released OpenWrt version, package or supported operation.

It is unlikely that you will receive useful input here.

Please seek advise from the relevant maintainer.

Using 18.6 now is insecure in itself.

Assuming this third party build isn't too far from official OpenWrt, adding option ttylogin 1 to the system block in /etc/config/system will require passwords on the local keyboard.


Thank you, mk24.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.