How can I confirm what runs on what?

For example, I am looking for hardware which will run specifically, openwrt 15.05.1 in ar71xx and ramips only. I'm not really sure how to find hardware that continues to be manufactured which will run these specific combinations for a while.

1 Like

You are searching for devices which are supported since <17.01.0 (filtered for ar71xx + ramips)


Searching, 17.01 is the oldest I can find. Maybe I am not understanding something?
Do you mean specifically,
I don't see ar71xx or ramips in that list however.

You do realize that 15.05.1 has not been patched for the numerous security vulnerabilities in 802.11, Linux kernel, and utility/application software.

OpenWRT 15.X can't be recommended for use under any circumstances due to those vulnerabilities. Any such use poses a risk to others as unsavory agents could use your compromised router as a jump point or link in another attack.

Not sure what you're looking for -- those are two, distinct architectures.

Perhaps if you clearly stated your use case and goals, people here could provide guidance.

ar71xx as target, but mips_24kc as package architecture

My intentions are that I run some old software that someone built for me several years back. it works on the gl.inet mt300n V1 but the v2 hardware won't run 15.05.1 unless I am missing something.

No mystery or anything unusual really, just need to keep using the older firmware. The router is not being used to route, does nothing interesting, just runs some control stuff I need for an old hardware project I had. The only open port is ssh so there really is no security issue.

Be aware of and other vulnerabilities in that three-year old version of dropbear

Format string vulnerability in Dropbear SSH before 2016.74 allows remote attackers to execute arbitrary code via format string specifiers in the (1) username or (2) host argument.

Best option would be to recompile your "custom" code for the current version of OpenWRT. It's pretty straightforward and would open you to future compatibility as well. If you need help with a Makefile for it, many here can guide you in the right directions.

If you're set on sticking with that unsupported, known-insecure version, I'd recompile current dropbear source either into a custom build of 15, or as a package to replace the vulnerable version. I'd also make sure that all ports are truly closed and that wireless isn't activated.

As mentioned, these aren't being used as routers so there is no remote access to them.
I'm not set on using older software and typically maintain all my systems to be up to date but again, as explained, in this case, it is custom software that I had written for me and I cannot have it re-written at this time. I'm not a programmer otherwise, I'd do just as you say and in fact, probably fix the software at the same time.

This is deviating from my original question however :).

Sure it has to be rewritten? Probably you have to compile it only with the sdk from 17.01 or 18.06...

Fine but that's not my question :).
I can't do it right now and need a way to keep this working for a while.

Ok, think we undestood... :roll_eyes:

So you want to know which device is supported on CC 15.05 (ar71xx and rampis) and is currently available on the market, right?


Thank you.
Correct. I need to run older hardware for a while longer so am looking for ar71xx and ramips mini routers that could run 15.05.1. The problem is, I don't know if that means all of those would run our the code or not.

All I know is that the TP-Link TL-WR703N and the gl.inet mt300n v1 work. Bonus would be findinga replacement that has one or two gigabit ports too.

Why not buy used hardware from ebay or something similar?
The TP-Link WDR3600 is supported on CC 15.05 and does also have gigabit ports...

Because I need a constant supply for a project and buying them used one here, one there is taking up all my time. I need to find something I can buy new as needed.

Wait, you need a "constant supply" of these? This is a commercial product/project where you're delivering firmware with known vulnerabilities?

Is this related to


which both appear to be Internet-connected use?

1 Like

Right, OP also said:

Seem like current to me.

If the software is pre-compiled, then it should work for the mips_24kc. Try installing 18.06 and see if you can run the binary. It might work (the C library might be your only issue).

Certainly sounds like it's doing a lot more than that.

Unless you can quickly and convincingly say what you are doing that requires an obsolete, insecure version of OpenWRT to run, I've got to conclude that it is a warez situation where you have illegal binaries compiled against that old version. I have no desire to support illegal activity and I would imagine that the forum has explicit rules against such activities.

Correct. I'm building and testing a network of cameras and am constantly having to hunt down used ones so would prefer to find a new replacement so I don't have to spend so much time hunting. I don't want to have to replace all the old cameras and just want to move forward with a new make/model that still runs my current setup/config.

I say I but there are a few of us messing around on this.

Please, your warez and/or commercial conclusion would be over the top as I'm not involved in anything of that nature at all. I would guess that most who are involved in those things have the technical skills to do what they need without having to post questions in public.

The routers are only being used as IP camera servers in and around my own property and a group of friends. No router functionality or anything else really, just an ssh port to change settings. It's a closed environment so I'm not concerned about security.

Anyhow, I'm not sure what you mean by using the mips_24kc. Does that simply mean that mips_24kc, version 18.06 is something that would run on my older routers?

Not so over the top given the evasive nature of your repeated lack of detail coupled with the fact that you've had a working build system up for some time now and could build from source your "special" code, if you had it.

So there clearly is a lot more "open" on these devices than a known-vulnerable version of dropbear. You may not be concerned about security, but you put your "group of friends" at risk, as well as everyone else on the Internet. Just for one, read