How about setup vlan with OpenWrt 21.02 for itpv

I used to have a mt7621 router,When running openwrt18.06,My itpv vlan settings:

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2 lan3 lan4'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'wan'
	option _orig_ifname 'wan'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'xxxxxx'
	option password 'xxxxx'
	option ipv6 'auto'
	option keepalive '0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '85'
	option ports '0t 1t 2t 3t 4t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '0t 1t 2t 3t 4t'
	option vid '51'

Then I changed to an x86 router,it running openwrt18.06,My itpv vlan settings:

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option _orig_ifname 'eth0'
	option _orig_bridge 'true'
	option ifname 'eth0 eth2 eth3'
	option dns '119.29.29.29 223.5.5.5'
	option ipaddr '192.168.0.1'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth1'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'xxxxxx'
	option password 'xxxx'
	option ipv6 'auto'
	option keepalive '0'

config interface 'iptv85'
	option type 'bridge'
	option ifname 'eth0.85 eth1.85 eth2.85 eth3.85'
	option _orig_ifname 'eth0.85 eth1.85 eth2.85 eth3.85'
	option _orig_bridge 'true'
	option proto 'dhcp'

config interface 'iptv51'
	option type 'bridge'
	option proto 'none'
	option ifname 'eth0.51 eth1.51 eth2.51 eth3.51'
	option auto '1'

Now i upgrade to openwrt21.02 with x86.I don't know how to set up vlan .My iptv needs vlan85 and vlan51, vlan85 needs to be set to dhcp client mode.At 18.06, I set up this way so that each lan port can provide iptv and Internet services.Because my iptv needs to get an IP address that can access the Internet, and at the same time get vlan's iptv through vid85.

i try to dettings:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth2'
	list ports 'eth3'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '119.29.29.29'
	option device 'br-lan'

config interface 'wan'
	option proto 'pppoe'
	option username 'xxxxxxx'
	option password 'xxxxxxx'
	option ipv6 'auto'
	option device 'eth1'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '85'
	option name 'eth0.85'
	option ipv6 '0'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '85'
	option name 'eth1.85'
	option ipv6 '0'

config device
	option type '8021q'
	option ifname 'eth2'
	option vid '85'
	option name 'eth2.85'
	option ipv6 '0'

config device
	option type '8021q'
	option ifname 'eth3'
	option vid '85'
	option name 'eth3.85'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-vlan85'
	list ports 'eth0.85'
	list ports 'eth1.85'
	list ports 'eth2.85'
	list ports 'eth3.85'
	option ipv6 '0'

config interface 'iptv85'
	option proto 'dhcp'
	option device 'br-vlan85'

IPTV can work。But I can't access any Internet。


I think it may be because there are two DNS addresses, resulting in a conflict?