Hostname resolution

I've installed OpenWrt on a Raspberry Pi. It gets it's IP adress from pfSense gateway via DHCP and I can ping the outside world by IP address but hostname resolution doesn't work. How do I enable this?

Configure the pfSense to hand out a working DNS server.

My pfSense box has been set up correctly for four years. I was missing something on the RPi but somehow have it working now.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

I've clicked the pencil behind the topic but nothing happens.

...then do the obvious and prepend [SOLVED] to your topic, then click the blue checkmark below.

I've just reinstalled OpenWrt on a RPi and after it booted up, I changed /etc/config/network so that it used DHCP rather than having a static IP address. Then after running /etc.init.d/network reload the IP address was updated but hostname resolution only started to work after a reboot. Is this to be expected?

Did you also reload the dnsmasq service?
/etc/init.d/dnsmasq reload

You should also disable the dhcp server on lan with option ignore 1 in /etc/config/dhcp on interface lan.

1 Like