Hostapd version bump

Hi all
I am trying to solve a quite big issue affecting the mwl8k based WiFi routers, see:

I think that the problem comes from hostapd. I see that in the current release and snapshot LEDE firmware, a git version of the 2.7-devel is used together with several patched.
I tried first to compile a clean hostapd, with no patches, but it fails to compile due to some inconsistence in supplicant.
Then I tried to bump to one of the last git commit, of course patches cannot be applied, the compilation reaches a good point, the hostapd packages are compiled fine, but then it fails at the wpda stages with:

make[3]: Entering directory '/home/menion/lede-sdk-17.01.1-kirkwood_gcc-5.4.0_musl-1.1.16_eabi.Linux-x86_64/build_dir/target-arm_xscale_musl-1.1.16_eabi/hostapd-wpad-full/hostapd-2017-05-10-33117656/hostapd'
cc1: note: someone does not honour COPTS correctly, passed 0 times
hostapd_cli.c:9:22: fatal error: includes.h: No such file or directory
compilation terminated.

the includes.h is of course present and hostapd_cli.c is not touched since ages, so I don't understand why it cannot find the includes.h
Can anyone help me on pointing where to work in order to fix it? Meanwhile I try to install the compiled part
--edit I have tried the compiled hostapd but it fails to startup

have you tried using wpad(-full) instead of hostapd ?

With wpad-full the WPA-EAP doesn't even work with the 5Ghz radio. Meanwhile, even if wpad fails to compile, I tested the hostapd git from 10 May, starting it manually. The stability is better but the througput is erratic, because the rebuffering in the mwl8k driver are still present. I really can't tell if the problem is with the driver (more probably) or with the hostapd. Unfortunately no one replied to my questions in Linux WiFi mailinglist