Hostapd uses wrong origin IP for radius request

Hey, I'm using OpenWRT 19.07.8 on an TPlink Archer C7v2.

I've configured a tinc VPN on the device to connect to the radius server. The interface is configured as dhcp client in LUCI.
The wireless interface is configured to connect to the radius server on the internal network.


config wifi-iface 'wifinet1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'ssid'
	option encryption 'wpa2'
	option auth_server ''
	option auth_port '1812'
        option auth_secret 'omitted'

Routing Table (excerpt):

default via dev pppoe-wan dev br-lan scope link  src dev br-lan scope link  metric 32 dev tincvpn scope link  src dev pppoe-wan scope link  src dev eth0 scope link  src 

But the router connects with its WAN IP to the radius server (through the vpn tunnel), after about 11 retries, it uses its private IP on the VPN tunnel to connect to the radius server and the authentication succeeds.
Error: Ignoring request to auth address * port 1812 bound to server default from unknown client port 54969 proto udp

Is there a way to tell the router to use the ip of a specific interface for its outgoing connections? Or better to use the interface IP for the corresponding route.