Hostapd logging to syslog-ng

Hi all
First post-wonder if I can get some help.
I have a bunch of TP-Link WDR3600's, which I normally run Openwrt CC on-found out about LEDE and made the jump. All works great but I have a specific problem...

I like to see hostapd messages in the syslog-and I get this on my CC boxes. I am using syslog-ng as the logger package (allows me to rotate logs etc). However, on my LEDE machines, I dont see any hostapd messages. I have tried changing the logging level but no joy. When I compare the two, I do see a difference in the hostapd daemon:

CC machine
root@N600-OPENWRT-GRD-BELL:~# ps | grep hostapd
2035 root 1356 S grep hostapd
14452 root 1604 S /usr/sbin/hostapd -P /var/run/ -B /var/run/hostapd-phy1.conf
15518 root 1612 S /usr/sbin/hostapd -P /var/run/ -B /var/run/hostapd-phy0.conf

LEDE machine
root@N600-LOBBY-LEDE-10:~# ps | grep hostapd
1421 root 1688 S /usr/sbin/hostapd -s -P /var/run/ -B /var/run/hostapd-phy0.conf
1463 root 1688 S /usr/sbin/hostapd -s -P /var/run/ -B /var/run/hostapd-phy1.conf
1929 root 1188 S grep hostapd

Looking at hostapd -h, the -s stands for log to syslog? Which is weird, as the LEDE machine isn't doing so!
My assumption is that the -s parameter isn't playing well with syslog-ng-before I remove syslog-ng to prove this, is there a way to change the hostapd (on startup I guess?) to omit the -s flag?



Not a great solution but getting rid of syslog, and using the inbuilt logread, with a "rotating" cronjob, seems to do the trick.