I am trying to use 2xAP+STA (AP0, AP1, wifiwan) on GL-MT300N-V2 , running 24.10.0
Quite often, after boot, I see flood of error messages,
daemon.notice hostapd: handle_probe_req: send failed
and wireless remains unusable.
Looks like, I ran into the open bug, described here:
opened 11:40AM - 21 Feb 22 UTC
on latest master code https://github.com/openwrt/openwrt/commit/cbfce9236754700a… 343632fff8e035acbc1b1384
AP + STA never work on 5G wifi
sta connected ok but AP no signal
channel is 44
mt76 driver tested on mt7915 or mt7612
config: /etc/config/wireless
```
config wifi-device 'radio0'
option type 'mac80211'
option band '2g'
option htmode 'HE20'
option phy 'phy0'
option hwmode '11g'
option disabled '0'
option country 'CN'
option channel 'auto'
option cell_density '0'
option txpower '20'
config wifi-device 'radio1'
option type 'mac80211'
option band '5g'
option htmode 'HE80'
option phy 'phy1'
option hwmode '11a'
option disabled '0'
option country 'CN'
option cell_density '0'
option channel '44'
config wifi-iface 'wifinet0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'X-WRT_68FE'
option encryption 'psk2'
option skip_inactivity_poll '1'
option wpa_group_rekey '0'
option wpa_pair_rekey '0'
option wpa_master_rekey '0'
option disassoc_low_ack '0'
option key '88888888'
option ieee80211r '1'
option ft_over_ds '1'
option ft_psk_generate_local '1'
config wifi-iface 'wifinet1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option encryption 'psk2'
option skip_inactivity_poll '1'
option wpa_group_rekey '0'
option wpa_pair_rekey '0'
option wpa_master_rekey '0'
option disassoc_low_ack '0'
option key '88888888'
option ieee80211r '1'
option ft_over_ds '1'
option ft_psk_generate_local '1'
option ssid 'X-WRT_68FE_5G'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'sta'
option network 'wwan'
option ssid 'Huawei_Wi-Fi5'
option encryption 'psk2'
option key '12345678'
```
log:
```
Mon Feb 21 19:29:18 2022 daemon.notice hostapd: wlan1-1: DFS-CAC-COMPLETED success=1 freq=5220 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5210 cf2=0
Mon Feb 21 19:29:18 2022 daemon.notice hostapd: wlan1-1: interface state DFS->ENABLED
Mon Feb 21 19:29:18 2022 daemon.notice hostapd: wlan1-1: AP-ENABLED
Mon Feb 21 19:29:20 2022 daemon.notice hostapd: wlan1-1: DFS-PRE-CAC-EXPIRED freq=5180 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5180 cf2=0
Mon Feb 21 19:29:20 2022 daemon.notice hostapd: wlan1-1: DFS-PRE-CAC-EXPIRED freq=5200 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5200 cf2=0
Mon Feb 21 19:29:20 2022 daemon.notice hostapd: wlan1-1: DFS-PRE-CAC-EXPIRED freq=5220 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5220 cf2=0
Mon Feb 21 19:29:20 2022 daemon.notice hostapd: wlan1-1: DFS-PRE-CAC-EXPIRED freq=5240 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5240 cf2=0
Mon Feb 21 19:34:35 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:34:37 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:34:40 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:34:43 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:34:55 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:35:00 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:35:18 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:35:43 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:35:44 2022 daemon.notice hostapd: handle_probe_req: send failed
Mon Feb 21 19:35:44 2022 daemon.notice hostapd: handle_probe_req: send failed
```
Can somebody confirm this bug on 25.10.0, too ?
Luker
April 5, 2025, 10:04am
2
BPI-R4 snapshot here (2025-04-04)
multiple AP on 2.4g, one AP on 5g and one on 6g.
It did not happen with the version of a couple of months ago (but I did have other ssh stability problems), now I can't reboot without this happening.
fortunately 5ghz is stable enough that I can just login, change really anything in the unusable 2.4g, apply and it works again.
I tried wpad-mbedtls
, wpad-openssl
, hostapd-openssl
hoping it would change anything, someone suggested introducing delays at boot, like:
wifi down radio0
wifi down radio1
wifi down radio2
sleep 5
wifi up radio1
sleep 90
wifi up radio2
sleep 30
wifi up radio0
but it does not help.
tried limiting to wpa2 only, wpa3 only, can't find anything that works.
I have a rough feeling it's due to having multiple SSID on 2.4ghz since 5g and 6ghz seem to work fine and I only have one ssid there.
The workaround is probably to limit yourself to 1 ap per radio.
Unfortunately I need an extra ssid for the IoT network