Hostapd_cli poll_sta doesnt work,always responce with OK even if STA is not in range (but still associatated to AP)[SOLVED]

I have been looking for a way to check if STA is still in range of an AP.
There is an option in hostapd ( max_inactivity) which does the check and if a STA not in range that STA will be dessatiatated and deauthinticated.
max_inactivity (300seconds by default)
Station inactivity limit in seconds: If a station does not send anything in ap_max_inactivity seconds, an empty data frame is sent to it in order to verify whether it is still in range. If this frame is not ACKed, the station will be disassociated and then deauthenticated.

I tried to use hostapd_cli from hostapd-utilites package but it doesnt work.

poll_sta <addr> = poll a STA to check connectivity with a QoS null frame

Sending a command like:
hostapd_cli -p /var/run/hostapd -i wlan0 poll_sta XX:52:XX:09:59:XX
will always responce with OK even if STA is not in range (but still associatated to AP)
The only diffrence nothing appearce in logread.

however every 300 seconds the AP checks it correctly and deassosiate inactive STA.
Is it a bag?
Is there a way to check is a STA in range?

I'd check the source code of the @dibdot's travelmate package.

i did ,but that is not it

Seems like the comand poll_sta is working correctly
and OK means the test frame was send and the answer needs to be catched form hostapd

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.