Horst: Can not switch channel?

I would like to use horst as spectrum analyzer. It is stucked to the first channel.
Even if I try to set the channel with -C I get following error:

root@OpenWrt:~# horst -s -C 2 -i wlan0
Could not open config file '/etc/horst.conf'
Set 'channel_scan' = 'wlan0'
Set 'channel' = '2'
Set 'interface' = 'wlan0'
nl80211 message failed: Object busy
INFO: A virtual interface 'horst0' will be used instead of 'wlan0'.
Got 2 Bands, 35 Channels:
1 : 2412 HT40+
2 : 2417 HT40+
Setting configured channel 2
nl80211 message failed: Object busy
ERROR: Failed to set CH 2 (2417 MHz) 20 (no HT) center 0
Max PHY rate: 0 Mbps

Anyone an idea? I even tried setting the interface to monitor mode.

What model device are you using?

I tried different ones.
For example the 5 GHz interface of a WDR 3400 has the same problem. :confused:

I can not even set the channel with iw.

You can't have any other interfaces defined on that radio, other than your monitor.