HooToo HT-TM01 - How to flash Stock Firmware?

I'm up and running :smiley:. After following the instructions here, I changed the LAN IP address, configured and enabled the wireless network, connected my laptop to the new wireless network, removed eth0 from the LAN interface, created a WAN interface with eth0 (DHCP), wired the TM01 into my 'upstream' network, and at that point it worked as a router. I then installed the TravelMate package, which allowed me to create the wireless WAN client connection. Last step was to install the OpenVPN client. All working well so far. Not fast when I use the wireless uplink rather than wired, but that's not surprising given it's using a single wireless radio.

2 Likes

Hmm. I was reading an old topic, and found this:

@arrmo 's device was a HT-TM05 (the red one) and reading again both your comments they look similar :confused:

Looks like you had to reprogram your device's flash chip with an external programmer.
At least you have backup. :see_no_evil:

I've noticed that apparently, the installation instructions to flash Stock Firmware on the HooToo HT-TM01 have a new URL.

Here's the correct URL for the OpenWRT installation instructions on the HooToo HT-TM01.

The link in my original post and in AberDino's report of a successful installation now seems to point to a nonexistent page.

I have now added a redirect from old -> new URL, i.e. old and new URL are working now.

2 Likes

This is how to restore the factory firmware of HT-TM02 using TFTP64 tested and worked, thanks for all the people contribute the resources:

  1. Download MTD bin backups (4~8) in step 2 from: https://drive.google.com/drive/folders/1XiEWeimv5pPtHeueD4U0fTVdcnYSKeeL

  2. now on windows, you can do the following to get the 2 files required for the refresh
    copy /b mtd4.bin+mtd5.bin+mtd6.bin+mtd7.bin kernel
    copy mtd8.bin rootfs

  3. Follow the Youtube tutorial but need both 2 files: kernel & rootfs, set the ip, plug in network, hold the reset then power on for 10~15 seconds then wait a few minutes will auto-refresh:
    https://www.youtube.com/watch?v=qPME1CLDT2o

  4. If you want openwrt, you can download wingspinner's firmware & rename it to kernel for update:
    https://github.com/wingspinner/HooToo-Tripmate-HT-TM02-OpenWRT/blob/master/ramips_openwrt/openwrt-ramips-rt305x-ht-tm02-squashfs-factory-r42649.bin

Not sure if TM01 will work since I don't have the unit, enjoy!!