one question, is this high cpu usage of the eth's normal?
Without any context, it'll be hard to answer that question.
Can you give more details?
What else to say? I am using OpenWRT v24 on FirtzBox 7530 and i see these high CPU processes. I think i haven't seen them on v23. Also there is not much traffic going on br-lan.
Maybe tell us about your configuration, any non-default packages you've installed, the devices connected to each port, the bandwidth consumption at the time you checked, etc.
And for that matter, maybe some idea of why you decided to look at the processes in the first place -- if you were nothing any performance issues, etc.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
Also redo the picture of htop enabling CPU usage detail graph. Any custom qdisc or more than dozen added firewall rules?
Well, i thought i'd start with the basics, maybe it's a known issue allready...
Would help me allready if someone knows this is not normal for a standard setup. but now for the full stuff:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdfa:847d:6e23::/48'
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'
config dsl 'dsl'
option annex 'j'
option tone 'b'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
option ipv6 '1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '64'
config device
option name 'dsl0'
option macaddr '2C:91:AB:51:CE:24'
option ipv6 '1'
config interface 'wan'
option proto 'pppoe'
option ipv6 '0'
option password 'xxxxx'
option device 'dsl0.7'
option username 'xxxxx@xxx.bbi-o2.de'
option keepalive '0 1'
option ip6assign '64'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
option reqaddress 'none'
option reqprefix 'auto'
config device
option name 'phy1-ap0'
option ipv6 '0'
config device
option name 'pppoe-wan'
config device
option name 'lan3'
option ipv6 '0'
config device
option name 'lan1'
option ipv6 '0'
config device
option name 'dsl0.7'
option type '8021q'
option ifname 'dsl0'
option vid '7'
option ipv6 '1'
config device
option name 'eth0'
option ipv6 '0'
config device
option name 'lan2'
option ipv6 '0'
config device
option name 'ip6_vti0'
option ipv6 '0'
config device
option name 'lan4'
option ipv6 '0'
config device
option name 'phy0-ap0'
option ipv6 '0'
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/a000000.wifi'
option band '2g'
option cell_density '0'
option country 'DE'
option channel 'auto'
option htmode 'HT40'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/a800000.wifi'
option band '5g'
option htmode 'VHT80'
option cell_density '0'
option country 'DE'
option channel 'auto'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option encryption 'psk-mixed'
option key 'xxx'
option network 'lan'
option ssid 'xxx'
option ieee80211r '1'
option mobility_domain '123F'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option bss_transition '1'
option wnm_sleep_mode '1'
option time_advertisement '2'
option ieee80211k '1'
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'ap'
option ssid 'xxx'
option encryption 'psk-mixed'
option key 'xxx'
option network 'lan'
option ieee80211r '1'
option mobility_domain '123F'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option bss_transition '1'
option wnm_sleep_mode '1'
option time_advertisement '2'
option ieee80211k '1'
config dnsmasq
option readethers '1'
option domain 'lan'
option local '/lan/'
option leasefile '/etc/dhcp.leases'
option expandhosts '1'
option nonegcache '1'
option localise_queries '1'
option authoritative '1'
option dhcpscript '/etc/dnsmasq/scripts/dhcp.sh'
list server '/intra/192.168.1.100'
option localservice '1'
option rebind_protection '0'
config dhcp 'lan'
option interface 'lan'
option start '150'
option limit '100'
option leasetime '12h'
list dhcp_option '42,192.168.1.1'
list dhcp_option '119,lan'
list dhcp_option '6,192.168.1.100,192.168.1.1'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
config host ...
fw3 is disabled. i use iptables only.
Sounds like you have a ton of non-standard things happening here. If you run a default 24.10.0-rc4 installation, do you see the same problems?
All of a sudden, everything went down. Thank God! Yeah, I have lots of stuff running: Netflow filter, Usteer, crazy stuff—fully loaded with everything OpenWRT has to offer.
It must have been some network traffic I didn’t notice.
Anyway, this thread can be used if anyone encounters the same issue.
Top heading from htop please.
Everything normal now. This is how i expect OpenWRT routers to be utilitized.
But still wondering if "NAPI" can be debugged deeper to get the problem...
Keep in mind that with critical network infrastructure, "fully loaded" is not necessarily a good approach unless you actually need those things. Specifically, the more you have running on your device, the more it may negatively impact performance. Additionally, you could increase your attack surfaces if you have additional services/daemons running (I'm not saying that the risks are high, but the more stuff that is running, the more likely it is that you could have a vulnerability that might be discovered). And, obviously the more stuff you have running, the more configuration you've got to do... meaning human error could be factor if you have any misconfigurations.
All that said, what you saw is apparently a spurious event... but even if it manifests again, you'll really need to be running closer to a standard configuration before anyone can really help determine if this is something unique to 24.10 or if it might be related to the packages and/or load that you have put on your router.