Hide/disable specific Chromecast and Airplay devices?

I got a few Chromecast and Airplay devices that I would like to hide from being listed as a castable device.

For example, my Denon receiver has Airplay built in which is not possible to disable (believe me, I have tried). I also got a Nest Mini and a Nest Hub, which will show up as Chromecast devices. I would never want to cast to my Nest Mini at any time and would like to declutter the list of devices, as I have many to select from + speaker groups.

Is it possible with some kind of firewall rule in OpenWRT to disable the ability for a device to present itself as a casting device, without disabling the device in other ways?

You can put the devices on a different subnet. But is is usually not possible to filter connections on the same subnet.

The one way it could work in the same subnet is to use bridge firewall, but this only works in certain situations.

https://openwrt.org/docs/guide-user/firewall/fw3_configurations/bridge

Like a guest network? Because the Nest Mini and Nest Hub is connected with Wifi, and the Denon receiver (Airplay) is connected with ethernet.

If these are put in a different subnet, will they be able to see other devices in the network. Because I need to be able to connect Home Assistant to my Denon receiver for example. And the Nest Mini and Nest Hub needs to be able to control devices in the network and cast to them (this might work through the cloud and maybe is not an issue).

Found this, however it mentions pfSense: https://www.reddit.com/r/PFSENSE/comments/mjo2xi/blocking_a_device_from_broadcasting_airplay_mdns/

It seems like it would be possible to make a firewall rule to block the AirPlay from the receiver as it is connected with ethernet. And all other devices are using Wifi, and if I understand correctly, this means that the router will handle this traffic even if it is in the same local network?

Does this look like the correct rule to block my receiver from mDNS broadcasting?
I'm unsure if it should be setup as src or dst?

config rule
	option name 'AVR-AirPlay'
	option src 'lan'
	option proto 'udp'
	option src_ip '192.168.1.38'
	option src_port '5353'
	option target 'REJECT'

or do I need to add this too:

	option	dest_ip		'224.0.0.251'
	option	dest_port	'5353'

Tried it, but got this error:

 * Rule 'AVR-AirPlay'
     ! Skipping due to different family of ip address