HH5a nand backup required

Hi I read the instructions
Went into putty got
ROM VER: 1.1.4
CFG 04
UART

Copied the asc file contents & pasted them into putty but instead of ****** I got the startup text 40 times
(ROM VER: 1.1.4
CFG 04
UART)

Tried rebooting and now boots straight to CFG 04

Thought I'd try to load OpenWRT/LEDE anyway as it would no longer boot

It came up invalid for OpenWRT 18 but appeared to load LEDE 17

But it's still booting to CFG 04

I'm guessing that my initial uboot attempt corrupted something

Has anyone got a nand backup so I can attempt to load OpenWRT/LEDE from scratch? Doesn't matter if it's BT or Plusnet etc as it's only for recovery purposes

Thanks

PS if there's anything else I can try let me know

I might have a nand back up somewhere but will need to look. What device (serial converter) did you use and has all your soldering been checked and is all your wiring good?

fwiw, if the HH5a repeatedly boots to CFG 04 UART prompt when bootsel_2 is not shorted to Ground, I'm afraid it looks like your HH5a may be suffering from 'stuck in CFG04 mode' syndrome. ie. hardware fault perhaps caused by poor soldering/too much heat or bootsel_2 being shorted to GND for far too long after power is turned on.

See section 7.3 of the installation guide. Restoring a nand dump won't fix the hardware fault in the experience of other users who had the CFG04 issue.

Hi the serial converter I used was a FTDI set to 3.3v


The wiring is ok, can take a picture if you like
The bootsel_2 point was only grounded for a second

I tried a couple of commands in uboot
BTHOMEHUBV5A # nboot

** No boot device **

BTHOMEHUBV5A # nand info

Device 0: nand0, sector size 128 KiB
Page size 2048 b
OOB size 64 b
Erase size 131072 b

I have read on one forum that someone fixed this by loading the Plusnet nand but the link is now dead, post was 2 years old

Thanks for the replies

check your PM for download link

Cheers for that, will try it after work & let you know

134Mb down to 18Mb, must be a lot of padding

Meant to test the 3.3v on the bootsel_2, will also check that just in case, if it has damaged the pull up resistor or 3v3 regulator then that's easy to fix

If neither work it'll end up in a weee bin & I'll buy a bridge as that's all I want it for, have a ethernet point 2 floors up without having to add wiring to put CCTV homebase in the loft

Well it's scrap, nand restore made no difference

There's 3v3 on one side of the pull up resistor, 0v2 the other

with it off theres only 8 ohm from bootsel_2 to ground, attempted to briefly short out R45 thinking that it'll either boot normally or blow the 3v3 reg, well neither happened, rather anti climatic

Attempted to look for the datasheet for the vrx268 / xrx200 hoping to see the sample circuit for the bootsel pins to see if there's a reason for it to be such a low resistance to ground or if there's a reason for the processor to internally pull the input down

Thank you both for your input and help

Can I please get the download link as well? My sysupgrade failed however I am not stuck in CFG04, so it should still be recoverable

Hi any chance of getting this download link also i can get the first two
parts to boot
but when i do a prepare it just goes to the #V9 prompt and wont go any further
i tired all the fixes for that Prompt but alas nothing happening i nearrly got it sorted.

I've uploaded a backup. The calibration data of each device is different so you may get yours working but there are no guarantees on the wifi quality when using someone else nand backup.

yeah i gathered that from some of the posts but thank you very much as least i can get it back up and running and try again totaly new to this so maybe if i get another one ill be more savvy

anyway much appreciatedfor taking the time to upload.

Hi has anyone have Nand Backup ? For HH5a ?

check your PM

Thank you !