HH5A bridging to WAN port

This network config file allows me to bridge the internal VDSL2 modem in the Home Hub 5A to the red WAN port at the back of the unit:

config atm-bridge 'atm'
	option payload 'bridged'
	option vci '35'
	option vpi '0'
	option encaps 'vc'

config dsl 'dsl'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option annex 'a'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.5.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr ':::::'

config interface 'wan'
	option _orig_ifname 'ptm0.101'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username ''
	option password ''
	option ipv6 'auto'
	option ifname 'ptm0.35'

config device 'wan_dev'
	option name 'ptm0'
	option macaddr ':::::'

config interface 'wan6'
	option ifname 'pppoe-wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0 1 5 6t'

config interface 'ptm035'
	option _orig_ifname 'ptm0.35'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '192.168.105.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ifname 'eth0.2 ptm0.35'

The HH5A internal LAN has no internet, however.
http://192.168.5.1/cgi-bin/luci/admin/network/network

Interfaces
Interface Overview
Network	Status	Actions
PTM035
 (eth0.2 ptm0.35)
br-ptm035
Uptime: 0h 24m 56s
MAC-Address: C2:FC:57:A6:43:5B
RX: 15.49 KB (312 Pkts.)
TX: 738 B (7 Pkts.)
IPv4: 192.168.105.1/24
Connect  Stop  Edit  Delete
LAN
 (eth0.1 Master "BTHub5AC"Master "BTHub5-C85Z")
br-lan
Uptime: 17h 30m 21s
MAC-Address: 84:A4:23:0F:5A:76
RX: 61.54 MB (282705 Pkts.)
TX: 336.97 MB (348281 Pkts.)
IPv4: 192.168.5.1/24
IPv6: fdbf:52eb:bcee::1/60
Connect  Stop  Edit  Delete
WAN
 (ptm0.35)
pppoe-wan
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)
Connect  Stop  Edit  Delete
WAN6
pppoe-wan

Physically connecting a LAN port from the external router to the HH5A LAN4 port and selecting WAN connection to LAN4 results in internet on the HH5A through DHCP from the external router:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '::::/48'

config atm-bridge 'atm'
	option payload 'bridged'
	option vci '35'
	option vpi '0'
	option encaps 'vc'

config dsl 'dsl'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option annex 'a'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.5.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr ':::::'

config interface 'wan'
	option _orig_ifname 'ptm0.101'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option ifname 'eth0.4'

config device 'wan_dev'
	option name 'ptm0'
	option macaddr ':::::'

config interface 'wan6'
	option ifname 'pppoe-wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '5 6t'

config interface 'ptm035'
	option _orig_ifname 'ptm0.35'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '192.168.105.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ifname 'eth0.2 ptm0.35'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0 6t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '1 6t'

http://192.168.5.1/cgi-bin/luci/admin/network/network

Network	Status	Actions
PTM035
 (eth0.2ptm0.35)
br-ptm035
Uptime: 1h 7m 52s
MAC-Address: C2:FC:57:A6:43:5B
RX: 32.69 KB (565 Pkts.)
TX: 738 B (7 Pkts.)
IPv4: 192.168.105.1/24
Connect  Stop  Edit  Delete
LAN
 (eth0.1Master "BTHub5AC"Master "BTHub5-C85Z")
br-lan
Uptime: 18h 13m 17s
MAC-Address: 84:A4:23:0F:5A:76
RX: 64.17 MB (295414 Pkts.)
TX: 340.12 MB (358610 Pkts.)
IPv4: 192.168.5.1/24
IPv6: fdbf:52eb:bcee::1/60
Connect  Stop  Edit  Delete
WAN

eth0.4
Uptime: 0h 7m 43s
MAC-Address: C2:FC:57:A6:43:5B
RX: 468.21 KB (1491 Pkts.)
TX: 307.62 KB (995 Pkts.)
IPv4: 192.168.16.155/24
Connect  Stop  Edit  Delete
WAN6

pppoe-wan

So basically the Home Hub 5 can act as a VDSL modem and handle the PPP connection while also acting as WiFi AP, all while using a different router for the actual routing? That's pretty neat if so.

Have you done any testing to see if heavy WiFi use slows the PPP connection down?

I tried to get the HH5A to share the pppoe through its red WAN port with a 2nd router, but at the cost of not being able to use the pppoe itself.
I haven't tried any speed tests on the wifi, but it shows up on the scan as present.

Answering my own question, the WiFi on the HH5 is massively bottlenecked by the CPU on LEDE (it can't get close to normal 802.11ac speeds) so its definitely going to slow down PPPoE if its used heavily.

I'm probably going to play around with this, although personally I will be trying as you said to just bridge everything over to my router so that can handle the PPPoE load. Mostly I'm just curious to see how the VDSL modem compares to the HG612 and getting some bonus Switch ports would be useful.

Has anyone here had luck to setup a 2nd router to manage everything else, and keep hh5 to just manage pppoe / modem only ?

Doing PPPoE on one device and bridging that traffic to another is a massive hack, I wouldn't recommend it. Far better to do PPPoE on the router and leave this as a plain bridge.

I've found it rock-solid stable when using it on VDSL2 in that mode, except on my G.INP line where it randomly resyncs for no obvious reason so I used something else on that one.

1 Like