HH5 Openwrt v19 Sync rate good, download rate s***

So the last HH5 I flashed with Openwrt I used version 17 and it ran well on Plusnet/BT fibre to the cabinet, but the last hub I flashed I used version 19 of Openwrt, latest build as of a few weeks ago (don't know the exact build until I check tomorrow) and the download sync rate on Plusnet service is 70Mb+ but I cannot get the download rate to exceed 18Mb.

To confirm, I have used the BT Wholesale Speed checker and also various local servers from Speedtest.net which all give me the same result. It is not a line issue as the old router and BT Openreach modem give both good sync and download rates of near 68Mb.

I've tried software offloading which actually seemed worse.
I've tried altering the MTU to 1500, 1508 and also turning off MSS clamping, but nothing seems to improve it.

I've also tried swapping between Annex A and B to no avail.
If I can't resolve it I will have to try downgrading to version 17 which seems backwards to me.

Any ideas please?


I used to have ~68mbps on my HH5a with Plusnet VDSL2 service. I used it up to OpenWrt 19.07.2.

Are you using 19.07 stable or 19.07 snapshot?

I presume speeds were checked over ethernet connection.

fwiw, it could be a routing issue through Plusnet network if it is not a congested exchange?

Two cases of low speeds reported lately.

Try leaving hub switched off for say 10 to 30 minutes, so it acquires a new WAN IP address on a different subnet and see if it resolves the problem.

I will check today.

Yes it was

When I checked with bt openreach modem and Thompson router speeds were very good. This was in the same timeframe as trying the openwrt hub.

That won't work as we have a static wan ip

If you use SQM, have you tried turning it off ?

Have you tried factory reset with 'minimal' set up?

1 Like