Hfsfsck broken in 18.xx relases, but works on latest 17.xx release

I am trying to trace the roots of this problem for some hours.

Command fsck.hfsplus that comes from package hfsfsck does not work on 18 releases.
Tried 18.06.01, than going back to 18.06.0-rc2, 18.06.0-rc1, 18.06.0. Same error (i'll describe).

But command works fine on 17.01.6 (latest 17 series release)

I also compiled my firmware from scratch, same error occurs @18 series version.

The error is the same on all tested 18 versions, output folows:

root@OpenWrt:~# fsck.hfsplus -c 5m /dev/sda1
** /dev/sda1
** Checking HFS Plus volume.
Trace/breakpoint trap

It stops with a trace message, wierd.

The same command works well on LEDE 17 series.

My experience on OpenWRT programming is at networking field, not on filesystems.

I´m asking some advice on what to look for to refine my efforts so I can focus on fixing this, or, to know if someone already had a similar problem so we can talk about it.


Forgot to mention: mips_24kc @ ar71xx generic target.

You're probably running into issues because the current version is from 2015 (!)

These are probably good starting points if you want to update hfsprogs


@pradorocchi you're going to want to run strace to see what's happening.

Thank you both for the replies, they are being essencial for me to work on this problem.

Sorry for this delayed feedback from me.

I´ll be posting news and progress here.

@pradorocchi any news? I faced the same issue while using fsck.hfsplus for OpenWrt 18.06.2 r7676-cddd7b4c77 build.

This is patched in commit cc8b7c. There was a 14-character string literal being allocated 28 chars, which tripped gcc's stack overflow protection and led to the trap.

1 Like