Here goes, another post with issues regarding the DL-WRX36

This post was originally asking how to failsafe and regain SSH access with additional request to help me get internet access. I have regained access to the router via SSH and Luci so now I would like to ask for help regarding internet connection, more specifically the WiFi is completey dead. Here is hopefully the necessary info...

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd08:9e3a:0d22::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Yeager 5G'
        option encryption 'psk2'
        option key '9109492505'
        option ieee80211w '1'
        option wmm '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/c000000.wifi+1'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Yeager'
        option encryption 'psk2'
        option key '9109492505'
        option ieee80211w '1'
        option wmm '0'

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

This looks very close to default and it should work but there's no country set on radio1. Set both radios to the same country. Also don't set wmm to 0, WMM is a requirement for 11n and higher modulations.

Thanks for the reply. I think I used those commands at an awkward time after I had changed a couple of settings. I assume WMM On would be 1 and that is how I have it now. I've also set the country code, prior to and after using these commands, to no avail.

What's odd is that I can connect to the WiFi channels of the router, but the WiFi just doesn't work. It even displays the connection strength in Luci, and the RX/TX rates...

I would take the wmm lines out entirely. Especially as a beginner the further you move from a default configuration the more likely it is to break.

That is a networking problem then. Most phones will disconnect if they can't get a DHCP address and reach the Internet.

So I should disable or enable WMM? There's just a checkbox and it's currently ticked.

And of course, I've been at this for hours but suddenly after your reply, my WiFi just magically works.

The default is the box ticked, which (despite the confusing description) must mean that WMM is enabled. So leave it that way.

Got it, thanks. If I have any more questions I'll refer to you, hopefully you don't mind, lol