Help with transmit/tx not working when connecting via serial to EAP1750H

I have an EnGenius EAP1750H that I wanted to get LEDE working on. The problem I've run in to is with the serial port. I can get output working properly, but no matter what I've tried thus far I can't get transmit to work. There are only 4 pins, so I know which is which and I've tried two USB TTL cables and used the TTL serial port on a raspberry PI. All can see the data being sent, none of them able to send data.

Is there a trick that folks with more experience know about to getting transmit to work in some cases? All my methods so far work just fine on other boards, but no transmit on this device. Any help would be greatly appreciated.

I just want to confirm...

When you say USB TTL...that means you also have the TTL 3/5 volt serial stepdown converter?

Yes. Two USB TTL adapters. One 3.3v and one 3.3/5v, both work for receiving, but nothing I've tried can transmit. Not to interrupt the boot loader or to get a console shell to spawn after the unit is done booting.

Verify:

  • Baud speed of the port (it could really be <= to what you have set, because you Rx)
  • Parity of port
  • Stop bits of port

What OS/software are you using to connect?

  • Lastly (and most difficult)...you may not be grounded between devices. Serial devices connected to each other must have the same electrical potential, and/or be equal to ground/Earth (or be very close).

So the problem is stranger than I had recalled when I made my post. I took your suggestions and tried things. I cycled through the all the parity options kermit gives me. Also tried twiddling stop bits.

Still getting readable data at 115200 baud, but as soon as 'Hit any key to stop autoboot' ticks to zero in the output there is a whack a gibberish written to the port without my touching the keyboard. Enough of the garbage happens that the boot loader thinks i'm sending bad commands and tells me to try 'help'. If I leave the Tx pin disconnected I get a screen full of clean boot output. So transmit kind of works, just isn't usable and my key presses seem to do nothing.

Maybe that's a hint to someone with more experience?

Hi, did you ever get lede to work on the eap1750h?

Still not supported.

Thanks. It's too bad. The hardware looks very similar to the epg5000 Epg5000
And then there is this Easywrt

Don't know where that came from...

Looking at the OpenWrt archive page, there is no mention of the EAP1750H at all...

https://wiki.openwrt.org/toh/engenius/start

There are several differences...

Capture

Try a loopback test on your USB device to rule it out.

You can do a loopback test by connecting the RX and TX pins together on USB serial device. Then you should be able to get back whatever you type in Kermit.

Hi, I have added two other engenius boards with the same situation

a resistor next to the TX pin must be removed
this resistor is connecting TX to ground

be careful because the other resistor is required
this resistor connects TX to the board trace

both the resistors are directly next to the UART pins

the numbers may not be the same, so you might want to verify with a multimeter
which resistor is connected to ground

from my commit for EAP1200H:

**Serial Access:**

  the RX line on the board for UART is shorted to ground by resistor R176
  therefore it must be removed to use the console
  but it is not necessary to remove to view boot log

  optionally, R175 can be replaced with a solder bridge short

  the resistors R175 and R176 are next to the UART RX pin at J10

Very cool. I tried this and I can now transmit and receive over the serial port. Sadly my motivation has passed on this a bit. If I find myself really motivated maybe I'll try to get OpenWRT booting on it.

actually I ended up getting one and I have images for it if you want