Help with setup VLAN on Netgear R8000

When I setup the VLAN, the VLAN setup would not work, but also the router does not response well, and I often have to reset it.

Move Ethernet cable from 1 port (unused for VLAN), into a port used by VLAN would show cable as unplugged (no blinking light).

I would like to use Lan port 1 (tagged) and Lan port 2 (untagged) for VLAN ID 3 and corresponding interface and Lan ports 3 and 4 for the default Lan interface.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda0:356d:85b7::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '10.0.20.1/24'

config device
        option name 'wan'
        option macaddr 'xxxx'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type 'bridge'
        option name 'br-children'
        list ports 'lan1'
        list ports 'lan2'
        option ipv6 '0'

config bridge-vlan
        option device 'br-children'
        option vlan '3'
        list ports 'lan1:t'
        list ports 'lan2'

config interface 'lan_children'
        option proto 'none'
        option device 'br-children.3'
config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:t'
	list ports 'lan2:u*'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '10.0.20.1/24'

config interface 'lan_children'
        option proto 'none'
        option device 'br-lan.3'