Help with OpenWrt and switch link aggregation configuration

config device
	option name 'bond0'
	option type 'bonding'
	list ports 'eth1'
	list ports 'eth2'
	option policy '802.3ad'
	option all_ports_active '1'
	option xmit_hash_policy 'layer2+3'
	option mtu '1500'
	option ipv6 '0'

config device
	option name 'bond0.1'
	option type '8021q'
	option ifname 'bond0'
	option vid '1'
	option mtu '1500'
	option ipv6 '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'bond0.1'
	list ports 'eth3'
	option stp '1'
	option mtu '1500'

config interface 'lan'
	option proto 'static'
	option ipaddr '10.159.1.2'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'br-lan'


Is there any problem with my configuration?

What device you are talking about?
What OpenWRT-Version are you talking about?

I’m talking about an x86 device with a 4125 processor. The OpenWrt version I’m using is ImmortalWrt R24-10.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Sorry for causing you any inconvenience. I think this place is quite professional, and I believe this network setup is related to OpenWrt’s kmod-bonding and proto-bonding. So, I’d like to confirm whether there’s any issue with my configuration.

Ask the immortal wrt team since it is an entirely different firmware and is what you are using. Or install openwrt (official) and er can help you here.

2 Likes

Besides you hit the wrong Forum more then half of your config is missing.

How to bond with OpenWrt is covered in the wiki and this forum so please search first.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.