Help with Netgear WNDR3700v5 - no lights except LAN


I'm new here but proud for having this interesting project. Recently i've saved to life WNDR3700v5 installing LEDE Reboot 17.01.1 r3316. Aparently everything is working superb and i've set up with LUCI the unit as a wirelles client in two minutes, but I miss the led lights indicating f.e. wireless activity, On or OFF, etc. At the moment only the LAN ones are working.

Can you please help me with the procedure to bring to life the other leds? What will be the package to install?

Thinks in advance.

connect to it with ssh and do what is explained here

Do you see the leds there? can you set the right trigger manually?


First very thinks for your answer, i really apreciate your help.

I've managed to assign "default on" to the power led but unfortunately when
the router is restarted this config was lost, returning to the initial
state (only lightning/flashing in the startup process).

Following the instructions I've tried to install the other leds (wireless,
usb) but despite being able to connect and download other packages these
particular ones refering to leds are not availlable: "Unknown package

I've tried to to set these options through Luci but i find this page a bit
confusing. Up to now the only leds that are workink normally are the four
LAN. The POWER and WPS light only during startup. The missing ones

From th router shell just in case you can give some clues:

root@WNDR3700v5:~# ls /sys/class/leds/
wndr3700v5:green:power wndr3700v5:green:wps

I had a look at the source , and as you can see only power and wps leds are defined there.
It seems that this device is doing like a similar device here and WAN, WIFI and USB are controlled by the wifi or switch or usb controller directly somehow (and the drivers for that aren't open source so it works only in the stock firmware, at least for now). But I don't know, maybe it was a mistake.

But it is wrong that the power led shuts down after startup. It should stay powered.

I've added the information to configure the leds permanently in the wiki now, you should be able to set up at least the power led.

For the wrong power led (and for missing leds about other things) you should report a bug here

Hi, thanks for yor replay.

I would like to report the bug of the missing leds but I dont know how to
do it. I'm registered in the LEDE fórum but I can guess how to report the
bug. Can you please help me with that?

Thanks in advance

Look at this: Reporting Bugs