Help with flashing AVM 300E - Powercycling timing?

Hey there i am a newbie and it is my first time trying to install OpenWRT :slight_smile: I've been using this amazingly well explained and detailed guide (this one) to flash an AVM Fritz!WLAN Repeater 300E, but i can't seem to even login into the ftp server via ncftp.

  • I used the ncftp client for windows.
  • I tried both:
    • giving myself a manual IPv4 adress:
    • trying it with automatically receiving it via dhcp.

My questions:

  1. Is there a special timing for the power cycling?
    • I tried hold the reset button (WPS button = reset button on this device) for 15 seconds, which according to AVM documentation should trigger a reset. Then within 3 seconds, i try to push the ncftp command: open -u adam2 -p adam2, but it fails to find a connection.
    • I tried to remove the repeater from power and plug it back in. Then within 3 seconds i tried to push the ncftp command.
    • I tried various other timings, but to no avail.
  2. What else could I try?

Putting an unmanaged switch between repeater and computer can help (avoids the link down/ link retraining). Yes, this tends to be timing sensitive and often needs several attempts.

On many other devices, there's an alternative approach. AVM is offering recovery firmwares for windows, using a wrong one (for another device) should leave the device accessible via ftp (but not flash the wrong recovery firmware).

Personally I'd prefer approaching this without using AVM's (wrong-) recovery firmware, but I'm not really a windows users eitherโ€ฆ (so at least give the former approach a few more tries).

It looks like using an unmanaged switch did the trick!

It only took me one try with that one. I used the reset timing where i pressed the wps button for roughly 15 seconds, waited until it started blinking heavily, then waited another ~ 2.5 seconds or so, then pushed the command. Then i can't remember anymore, if it was working asap, or if i by reflex closed the ncftp programm, restarted the programm and immediately pushed the command again (sorry, bad memory), but it worked. If i compare that to the roughly 20-30 trials i went through where it did not work, i highly suspect the switch made the difference.

All the rest worked like a charm :slight_smile:

And thank you @slh for the almost instant reply!

1 Like

I bricked my configuration. Don't ask. Because the physical reset button does not work on this device with Open WRT and i was not able to ssh in, i had to flash the device again.

I now can confirm that the easiest and fastest way to trigger the ncftp flash process is to connect to the Repeater using an unmanaged switch, turning on the device (=plugging it into the electrical socket), waiting for ~ 2,5 - 3 seconds and then to push the open -u adam2 -p adam2 command

The 15 seconds method does not work anymore, after Open WRT was installed once, it only works with original AVM firmware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.