For context I don't know much about networking, I have two devices both running OpenWrt 23.05.04, the devices are the HH5a and Tp-Link Archer AX23. My home has a phone line so I bought the HH5a to provide modem functionality while the Archer would be the main router.
I live in the UK with an Openreach Isp, I got my HH5a modem working by following this tutorial, when I tried to follow the steps for configuring the HH5a as a bridge modem I couldn't follow it because I believe the guide was for an earlier version of OpenWrt, for example in the interfaces edit modal, there is no physical settings tab.
So far I've changed the Archer's IP address to 192.168.5.1 and set it's gateway to the HH5a's IP address of 192.168.1.1, I connected the Archer's WAN port to one of the HH5a's LAN ports which has given me connectivity. I believe for a bridge modem I'm meant to disable DHCP, Firewall and NAT, and possibly disable SSH for extra security but this is where I'm lost and need help with if anyone would be kind enough to assist me.
HH5a /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd33:935b:9630::/48'
config dsl 'dsl'
option annex 'b'
option tone 'a'
option xfer_mode 'ptm'
option line_mode 'vdsl'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr 'a8:9a:93:06:42:64'
config device
option name 'lan2'
option macaddr 'a8:9a:93:06:42:64'
config device
option name 'lan3'
option macaddr 'a8:9a:93:06:42:64'
config device
option name 'lan4'
option macaddr 'a8:9a:93:06:42:64'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'dsl0'
option macaddr 'a8:9a:93:06:42:65'
config interface 'wan'
option device 'dsl0.101'
option proto 'pppoe'
option username '**************'
option password '*******'
option ipv6 '1'
Archer AX23 /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd46:0599:4aae::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.5.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'