Help with BT Home Hub 5 and Virgin Media

Hello all

Sorry for the newb question but I just purchased a BT ome Hub 5 from eBay with OpenWRT preinstalled.

My current ISP is Virgin Media and I use their Virgin Hub in "modem mode". I have a Belkin router with a custom firmware based on DD-WRT which doesn't support OpenVPN and I purchased this BT thing just for that.

But I can't get it to work!

I looked at so many forums, so many Google Searches, but I simply can't get it working. I had to go back to the old Belkin just to get the internet back on and come look for help.

I know it may be too much to ask, but can anyone help me with a step-by-step? I know a bit of networking and a bit of Linux, but I can't understand anything on the LuCI OpenWRT and everything is so different from what I'm used to.

The BT Smarthub is Powered by LuCI openwrt-19.07 branch (git-20.057.55219-13dd17f) / OpenWrt 19.07.2 r10947-65030d81f3 and all the forums I found have solutions for a different GUI and I'm ultra lost here.

I have the BT hub connected to Virgin Hub via WAN port but it seems like this is not what I'm supposed to do, right?

Help would be much appreciated.

Thanks in advance. has information about this device in general and UK ISPs in particular.

Thanks for the reply. I read this already. This is only information about VDSL.

Virgin Media in the UK provides a cable modem/router combo which can be set up as a modem-only. This modem MUST be used and you can't replace it by anything else.

All I am trying to do is get the OpenWrt BT thing to work as a router only and get an IP address from the Virgin Hub.

I use the Virgin Media Hub 3.0 in bridge/modem mode with Openwrt

It suffices to define your wan interface thus

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'
    option broadcast '1'
    option macaddr 'xx:xx:xx:xx:xx:xx'

The big "gotcha" and the one I imagine you are experiencing, is that if you have been connecting to virgin media with a different device, then there will be a dhcp lease for your account registered on their server. It will NOT let you connect with another mac address while that lease has not expired.

So you MUST clone the mac address of whatever device you were using previously (the wan interface of the dd-wrt box) on the new openwrt device.

(of course, you need to make sure the interface name is the right one for your device)

Sorry, how do I define this wan interface?
Command line?
If so, how do I command line the device?

I feel like an idiot lol

the piece I posted you will find in the /etc/config/network file. Or you can use the gui to set it up the same way. Just make sure to clone the mac address. That's what the option macaddr does.

Just look at the options and replicate them in the gui

where do I find it in the gui?

how did you configure the device in the first place? gui = luci

http://ip address of your router

then go to menu->network->interfaces

choose WAN, set it to dhcp

change it to the right physical interface

check the broadcast flag

go down to the mac address and put in the mac address of your belkin dd-wrt box

Thank you VERY MUCH for the help at this time of the night, mate. You saved lives here.

I messed up connecting the cables at the very end (going up and down the stairs) but it worked perfectly!

Just one more question. The OpenVPN tab disappeared?

Did you update the package list and download the openvpn packages?

Have you studied the openvpn setup guide?

ps. Please change the title of the thread. It is a 'Home Hub 5', and NOT a 'smarthub'.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.