Help with batman-adv

how do I give access to the internet in bat0 ??

config interface 'loopback'                    
        option device 'lo'                     
        option proto 'static'                  
        option ipaddr '127.0.0.1'              
        option netmask '255.0.0.0'                   
                                                     
config globals 'globals'                             
        option ula_prefix 'fd5a:7631:81cd::/48'      
                                                     
config device                                        
        option name 'br-lan'                         
        option type 'bridge'                         
        list ports 'eth0'                            
        list ports 'bat0'                            
                                                     
config interface 'lan'                               
        option device 'br-lan'                       
        option proto 'static'                        
        option ipaddr '192.168.1.20'                 
        option netmask '255.255.255.0'               
        option gateway '192.168.1.1'                 
        option ip6assign '60'                        
        list dns 8.8.8.8                             
                                                     
config interface 'bat0'                                                                       
        option proto 'batadv'                                                                 
        option routing_algo 'BATMAN_IV'                                                       
        option aggregated_ogms '1'                                                            
        option ap_isolation '0'                                                               
        option bonding '0'                                                                    
        option bridge_loop_avoidance '1'                                                      
 option bridge_loop_avoidance '1'       
        option distributed_arp_table '1'       
        option fragmentation '1'               
        option gw_mode 'server'                
        #option gw_sel_class '20'                    
        #option gw_bandwidth '10000/2000'            
        option hop_penalty '30'                      
        option isolation_mark '0x00000000/0x00000000'
        option log_level '0'                         
        option multicast_mode '1'                    
        option multicast_fanout '16'                 
        option network_coding '0'                    
        option orig_interval '1000'                  
                                                     
config interface 'mesh'                              
        option proto 'batadv_hardif'                 
        option master 'bat0'                         
        option mtu '1536'                            
                                                     
config device                                        
        option name 'br-default'                     
        option type 'bridge'                         
        list ports 'bat0'                            
                                                     
config interface 'default'                                                                    
        option device 'br-default'                                                            
        option proto 'static'                                                                 
        option ipaddr '192.168.10.1'  ##static address on the new 192.168.10.0/24 network pool
        option netmask '255.255.255.0'                                                        
  #     list dns '1.1.1.1'  ##comment out to enable cloudflare dns                            
        list dns '8.8.8.8'  ##comment out to disable google dns                               

this is my wireless configuration

I want to give access to HomeWAP.
how can I do this

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '153'
        option txpower '21'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
       #option htmode 'HT20'
        option country 'BR'
        option disabled '0'

        #option type 'mac80211'
        #option path 'pci0000:00/0000:00:00.0'
        #option channel '36'
        option band '5g'
        option htmode 'VHT80'
        #option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '1'
        option txpower '20'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option country 'BR'
        option disabled '0'

        #option type 'mac80211'
        #option path 'platform/ahb/18100000.wmac'
        #option channel '1'
        option band '2g'
        option band '2g'                         
        #option htmode 'HT20'                 
        #option disabled '1'   
                                                 
config wifi-iface 'wmesh'                     
        option device 'radio0'                
        option network 'mesh'                    
        option mode 'mesh'    
        option mesh_id 'MeshCloud'
        option encryption 'sae'                  
        option key 'MeshPassword123'
        option mesh_fwding '0' 
        option mesh_ttl '1'                      
        option mcast_rate '24000' 
        option disabled '0'    
                                                 
config wifi-iface 'whome'                       
         option device 'radio1'
         option network 'default'                
         option mode 'ap'         
         option ssid 'HomeWAP' 
         #option encryption 'psk2+aes'                 
         option disabled '0'

is this the EAP-225 from this post ?

This is also a good tutorial for batman-adv configuration on OpenWRT : https://openwrt.org/docs/guide-user/network/wifi/mesh/batman
it will be easier to give configs if we know what "layout" your network is or what you are trying to achieve for example with only 2 mesh devices ( I made the drawing with draw.io ) :

or with 3 ( and more) devices


You can also search the forum for @jeff 's posts to fond many BATMAN related posts and configs

this
I managed to make it have output to the internet. is making a mistake on the firewall.thanks for the tips and pictures.
now I'm going to work on authentication via the portal.
I want to try to generate an apk also for mobile authentication. I still have no idea how.

let's go to research and studies. if there's anything i can help give a direction i appreciate it a lot.

I'm trying to generate a community network.
I thought of putting a panel in a small tower I have, transmitting a signal with an output to the internet through that panel and spreading the eap225 at points where the target panel is, to generate a high availability mesh.

that's the idea in my head.