[HELP] Urgent please, TL-WR740ND v4 updated and can't install xl2tpd

Hi mates, loving you for the support you give me,
today I had the bad idea to update router to openwrt cause I couldn't imagine it doesn't contain L2TP protocol, yesterday I updated the TP-LInk AP and works fantastic with openwrt..
Now I don't have internet and I need it urgently, I don't know how to install xl2tpd cause opkg update +
opkg install xl2tpd install mostly all but give am error:

Configuring kmod-udptunnel4.
Configuring kmod-udptunnel6.
Configuring kmod-l2tp.
Configuring resolveip.
Configuring kmod-pppol2tp.
Configuring ppp-mod-pppol2tp.
Collected errors:
 * pkg_write_filelist: Failed to open //usr/lib/opkg/info/xl2tpd.list: No space left on device.
 * opkg_install_pkg: Failed to extract data files for xl2tpd. Package debris may remain!
 * opkg_install_cmd: Cannot install package xl2tpd.
 * opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: No space left on device.

with df command before I had 90KB, now 40. opkg doesn't let me remove anything, there is always no space left (even for uninstall??). I've tried to remove all (mtd -r erase rootfs_data) it didn't help. How and what can I remove to revive my internet connection?
Strange this router has 16MB flash and not only 4, but some partition are only 320KB? How can I expand them? I have a LOT of free space on other partitions:

/dev/root                 2304      2304         0 100% /rom
tmpfs                    13908      1180     12728   8% /tmp
tmpfs                    13908        48     13860   0% /tmp/root
tmpfs                      512         0       512   0% /dev
/dev/mtdblock3             320       280        40  88% /overlay
overlayfs:/overlay         320       280        40  88% /

TL-WR740N v4 has only 4MB of flash (not 16MB).
4MB is too little for current OpenWrt.

See https://openwrt.org/supported_devices/openwrt_on_432_devices what you can do now.

To permanently solve this issue, you should get a new device with sufficient ressources for current OpenWrt (16MB Flash / 128MB RAM).


thank you for your kind quick answer, what can I do? I can survive with security issues of version 15, but does it has L2TP of will I face the same problem?
Can I remove manually any file to let a bit of space to install L2TP? I don't need PPPoE for example.
ABout building the release. I don't have linux (( can kindly somebody do this for me?
Thank you really a lot!

I try to solve myself but this is really complicated. I want to flash version 15 but I can't find it :#

Use Image Builder to make an image with the packages you need, and remove those you don't need like ppp and ipv6.

1 Like

From https://openwrt.org/supported_devices/openwrt_on_432_devices (you really should read this):


I have a TP-Link TL-WR720N v4, which I flashed that build and working fine as a dump AP.

Basic NAT routing works, but not sure if it has the packages you needed. Please note it does not include opkg.

1 Like

Today it's a (bad) day I'll never forget.
My internet is poor, when I share it from phone to pc I don't know why this forum not working. Unluck over unluck.
I tried do everything myself and I spent the last 12 hours over it.
I flashed by sysupgrade ddwrt hoping it contains l2tp but all went corrupted, http I can't access, ssh not working. So I sold on board and accessed by serial, I can't stop boot with 'tlp' code, it boots and I can't stop it with control C, if I open again serial then I have consolle, busybox, but quite all Linux commands doesn't work. I typed nvram erase and erase nvram, didn't help, so I decide to erase flash and now bingo.. also the bootloader is gone. I didn't know and never read that bootloader was so easy to remove.
My router is dead, and in Google no articles about me, seems I'm the only unlucky guy who lost bootloader. Crazy day

Cool, you just lost an old device worth no more than 3 euros, and with the price of 3 euros, you have learned that the flash should not be erased without a programmer in hand.

So this is a good day for you.

1 Like

Not at all, I've lost 12 hours for nothing. And just because openwrt doesn't support l2tp natively :grimacing:

It does, it's your device that doesn't have sufficient flash space to fit it.

That's hardly Openwrt's fault.


Does ddwrt implement l2tp or the same problem?

that, you should ask over at ddwrt.

But your flash space won't grow by switching firmware.

1 Like

Original FW has... maybe if there is lack support for not useful (to me) services it may be possible

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.