[Help] Upgrading WRT1900ACS 19.07.7-->22.03.0 Can't get PPPoE to work on WAN with VLAN

Finally getting around to upgrading from 19.07.7 to 22.03.0 on my Linksys WRT1900ACS (v2). Flashed ok, with no config as I'll obviously have to redo everything with the DSA changes.

I've read what I can but I am stuck attempting to get PPPoE to work over the WAN port using a tagged VLAN.

I have tried any number of configs at this point but am failing to see any Rx on the WAN interface at all. I am seeing PPPoE PADI broadcasts going out (appropriately tagged), but nothing coming back. I have this working no issues on my 19.07.7 install so we can rule out a lot of silly stuff.

Feels like I'm missing something fundamental, but can't see anything from the docs and other threads.

Not sure configs will help at this point as I've been playing too much...but will happily post anything to help.

Basically, I have added the WAN switch port to the br-lan bridge device and enabled VLAN filtering.
I've added two VLANs:

VLANID 1 - LAN1 - LAN4 (untagged)
VLANID 101 - WAN (egress tagged)

I have then changed the LAN interface to use br-lan.1 and the WAN interface to use br.lan.101 (and configured for PPPoE and modified the MTU).

Anything obvious?

Let me know anything else I can add to help...
This seems like it's a pretty common use case, so hopefully someone can save me from myself!

Many thanks,
RIchard.

It should just be wan.101 for the wan interface.

Why are you trying to use your LAN bridge as your WAN interface? There is no need to use a bridge if you need to tag just a single interface.

This is how I have my WAN (tagged VLAN ID 10) set up. Port 8 is in use for WAN. name is optional but helps telling it apart.

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'p1'
        list ports 'p2'
        list ports 'p3'
        list ports 'p4'
        list ports 'p5'
        list ports 'p6'
        list ports 'p7'
        list ports 'sfp'

[...]

config device
        option type '8021q'
        option ifname 'p8'
        option vid '10'
        option name 'fiber'

[...]


config interface 'wan'
        option proto 'pppoe'
        option username '****************************'
        option password '**************************'
        option ipv6 '1'
        option device 'fiber'


Thanks for the reply...

Is that without adding the wan port to the br-lan bridge then?
Just adding a 101 VLAN to the wan device?

I tried that first with no success, but I will give it another go if I'm understanding you correctly!

The wan should not be bridged with the lan in your config.

Post your config file if you want specific guidance:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

Mainly because another thread pointed me in that direction and I failed to get it to work just adding the VLAN.

It's my first time trying to get this to work with DSA and I feel like I missing something fundamental in my understanding of what is going on.

I'll have another play based on your config.

OK, I reset and reconfigured without bridging the wan switch port as suggested, still no luck - below is my config:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8c:d785:24da::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'XX:XX:XX:XX:XX:XX'
        option ipv6 '0'

config interface 'wan'
        option proto 'pppoe'
        option device 'wan.101'
        option username '*************************************'
        option password '*************'
        option keepalive '2 1'
        option mtu '1492'
        option ipv6 '0'

config interface 'wan6'
        option device 'wan.101'
        option auto '0'
        option proto 'none'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '101'
        option name 'wan.101'
        option ipv6 '0'

I have installed tcpdump so can see the egress broadcast packets are tagged:

root@OpenWrt:~# tcpdump -vvvv -nnnn -i wan -e
tcpdump: listening on wan, link-type EN10MB (Ethernet), capture size 262144 bytes
03:31:09.036055 XX:XX:XX:XX:XX:XX > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 36: vlan 101, p 0, ethertype PPPoE D, PPPoE PADI [Service-Name] [Host-Uniq 0x403E0000]
03:31:14.041113 XX:XX:XX:XX:XX:XX > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 36: vlan 101, p 0, ethertype PPPoE D, PPPoE PADI [Service-Name] [Host-Uniq 0x403E0000]
03:31:19.046055 XX:XX:XX:XX:XX:XX > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 36: vlan 101, p 0, ethertype PPPoE D, PPPoE PADI [Service-Name] [Host-Uniq 0x403E0000]
03:31:26.266058 XX:XX:XX:XX:XX:XX > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 36: vlan 101, p 0, ethertype PPPoE D, PPPoE PADI [Service-Name] [Host-Uniq 0x933F0000]
03:31:31.266235 XX:XX:XX:XX:XX:XX > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 36: vlan 101, p 0, ethertype PPPoE D, PPPoE PADI [Service-Name] [Host-Uniq 0x933F0000]
5 packets captured
5 packets received by filter
0 packets dropped by kernel

As I mentioned earlier I am seeing no RX at all on the wan port:

root@OpenWrt:~# ip -s link show wan
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff permaddr XX:XX:XX:XX:XX:XX
    RX:  bytes packets errors dropped  missed   mcast
             0       0      0       0       0       0
    TX:  bytes packets errors dropped carrier collsns
          4428     123      0       0       0       0
root@OpenWrt:~# ip -s link show wan.101
93: wan.101@wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    RX:  bytes packets errors dropped  missed   mcast
             0       0      0       0       0       0
    TX:  bytes packets errors dropped carrier collsns
            64       2      0       0       0       0

Appreciate any insights...

Try this:

config interface 'wan'
        option proto 'pppoe'
        option device 'wan.101'
        option username '*************************************'
        option password '*************'
        option keepalive '2 1'
        option mtu '1492'
        option ipv6 '0'

config interface 'wan6'
        option device '@wan'
        option auto '0'
        option proto 'none'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '101'
        option ipv6 '0'

You do not need to specify the name for the 8021q type device. OpenWrt will pick that up by itself AFAIK if you stick to $DEVICe.$VLAN_ID in your interface definition.

Thanks for the suggestion.

Made no difference to the behaviour sadly.

Just FYI the original config was created entirely via the luci web interface.

I also attempted to upgrade to 21.02.3 just to make sure there wasn't something in the 22 stream that I was hitting.

Unsurprisingly the same result. I seem unable to get any traffic from the WAN interface under DSA - anyone have any other ideas or diagnostics I can try to get a handle on what is going on here....

Appreciate any help....

Bump ..

If there are no further suggestions on how I can debug this I guess I'll be arriving to the 19 stream coffee for a while...

You can test something like this:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '***:****:****::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan.1'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option ifname 'wan.101'
	option proto 'pppoe'
	option force_link '1'
	option username '***************'
	option password '***************'
	option ipv6 'auto'
	option device 'wan.101'

config device
	option name 'wan.101'
	option type '8021q'
	option ifname 'wan'
	option vid '101'

good luck :wink:

Thanks for the advice and link..
Your thread was the one that led me down the path of adding the WAN port to the br-lan bridge at the start of this thread. Which was advised against above....

I'll have another go as I could easily have messed it up as I hadn't played with OpenWRT config for quite a while!

I'll let you know how I get on once I get a chance to try it!

1 Like

Hello,
Have you managed to get the setup working? If so would you mind posting your network file?
Peter

Hi @peterb99

Sadly, no I don't have this working.
Nothing I try seems to get it going and I ran out of time to look at it.
I will take another look soon and will update if I get anywhere with it.

Richard.

Hi Richard,
I have a WRT3200ACM on 22.03 R1 and it kind of works, but most data traffic seems to go via wan6, not sure it should be like that.
My network file:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        list dns '208.67.222.222'
        list dns '208.67.220.220'
        option ipv6 'off'
        option delegate '0'

config device
        option name 'wan'
        option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'bthomehub@btbroadband.com'
        option password 'test'
        option ipv6 'off'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

I finally got back to look at this, using 22.03.2.

I repeated just about all the steps I tried before and anything else I could think of, but still had the same issue.

Stumbled across this thread and it just popped up working.

Not sure why this works when setting a specific 802.1q device doesn't....but I can live with that. Just updating this topic in case anyone else is still struggling to get this to work!

Basically, configure your PPPoE settings (via LCUI) and then edit the wan interface in /etc/config/network and set:
option ifname 'wan.101'

Right, now to redo all the rest of my config!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.