Help unbrick Tp-link RE200 V4 extender, wont stay powered on

Hello,

while doing a manual update for my extender over wifi (big mistake on my part) it powered off....

now when i plug it in it starts to power up then only the power LED stays green for a few seconds then power off, tried the reset button without any result...

I opened the device and soldered the connectors but it wont stay on for more than a few seconds...

any way to recover from this catastrophe? or is trashed?

While that isn't really recommended, it shouldn't be a problem either - at least modern targets have image meta data attached (which include a checksum) that would sysupgrade to refuse flashing (and simply rebooting instead) a corrupted image (unless you --force the flashing). sysupgrade also detaches from the network before it actually starts flashing, so a loss of connectivity wouldn't cause any harm either - a power loss during the upgrade would be a real issue though.

which is weird and shouldn't happen (again, a sudden powerloss during the flashing can be fatal).

If you have a serial console attached, you should see what is happening and be able to describe (and paste the log) a bit more exact, there are basically two options:

  • the flashed image fails to boot
    • either the bootloader notices something amiss are reboots the device in close succession
    • or the kernel/ firmware starts to boot, before failing a little later in the boot process (and probably gets rebooted by a watchdog)
  • the device suddenly shuts off (which is what I'd read into your description, but what's also a bit less likely to happen as a result of your described failed flash), here it really matters what exactly happens at which point into the boot process

The former case should be fixable (quite easily), as you already have a serial console attached (and working?) - as long as the bootloader is undamaged, can be interrupted and instructed to load an initramfs image for fixing.

The later case sounds more like a real hardware damage, which is unlikely to have been caused by an interrupted flash process.

the serial console does not return any output, seems like the bootloader is damaged... i even tried switching TX and RX still nothing....

Please post an image of your connections.

Amat

you could only fixed this by a flash programer

turnd out that my serial adapter was faulty..... now the unit is flashed and fixed... thank you all

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.