Help Turning On IPv6 in OpenWrt

My ISP (Spectrum) claims that they offer dual stack, native IPv4 and IPv6 to their customers where I live (Central Florida).

My modem (Arris 6190) is supposed to be compatible with IPv6, by everything I've read online.

I'm running 19.07.2 on a Linksys WRT1900AC v.1. It's a fairly uncomplicated setup. Here are the packages I've installed in addition to anything installed when I flashed OpenWRT:
luci-app-advanced-reboot, luci-app-ddns, luci-app-sqm, luci-app-watchcat, luci-app-wifischedule, luci-app-wol, nano, speedtest-netperf, wget.

I was running an IPv6 6in4 tunnel (Hurricane Electric) but I've removed those settings and packages.

I can't seem to get an IPv6 address from Spectrum.

What am I doing wrong? What do I need to do for this to work?

Thanks in advance for your help.

FWIW, I connected my Chromebook and another laptop directly to the modem and ran a test at IPv6 came back as "Not supported". Both devices connected to an IPv6 6in4 tunnel successfully in the past.

So it has to either be the modem or the signal from my ISP, right?

pretty much. call spectrum, maybe they can push a modem firmware fix or something... worth a try

I've tried three times - 2 different calls and one chat on Facebook. None of them has any way to help and no technical information about the IPv6 dual stack to share. I'm pretty frustrated.

they probably just haven't rolled it out to your local loop. either that or your modem is incompatible... but you say online indications are it should work... so most likely they haven't rolled it.

It was supposed to be IPv6 compatible when released a few years ago.

I'm going to try to pick up a modem from Spectrum and see if anything is different. That way I'll know if it's a configuration error on my part, or a technical error on Spectrum's fault. I'll try to report back tomorrow if I can.

1 Like

FYI, for anyone reading and following this thread, there is nothing wrong with the default IPv6 settings in OpenWrt.

I got a modem from my ISP and IPv6 worked immediately upon activation of that device. The modem I owned (Arris SB6190) either doesn't work properly, or has a problem with Spectrum.

So if you're like me and wondering why IPv6 isn't working, try a different modem. It made all the difference.

Thanks to all who chimed in with their support!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.