Help! TP-Link C2600 Upgrade 18.06.2 Password Invalid

I have a TP-Link C2600 and just tried upgrading to 18.06.2. All went well until I tried to access my router and I receive "invalid username and password". I have been using LEDE/OpenWRT for 4+ years now and I have never expereinced an upgrade problem like this.

I downgraded to 18.06.1 and attempted to restore my backup generated on 9 Jan '19, and again I receive invalid password / username. This is inspite of trying setting a password and not setting a password scenarios multiple time.

Thanks for your help.

Do you have the issue if you don't restore the password?

I'm not exactly sure what you mean. I have tried entering a new password, using my old password, and not entering a password when I upgrade. If there is an option in the backup to not restore the password, I don't know how to do that.

Does it happen on webif or ssh too?
Are you able to login with keys on ssh and troubleshoot from there?

When I ssh I have the same problem, even though I am sure to set dropbear to the lan only setting in luci. I am kicked off after 3 unsuccessful tries.

I don't know webif and don't use it.

Webif = Luci Web Interface.

Let me suggest something.

  1. Reinstall 18.06.2 (or .1 it doesn't matter)
  2. Change the password to the one you want.
  3. Open /etc/shadow and copy the line of the root
  4. Replace the line in the shadow file of the backup.
  5. Restore the backup.

Thanks for the tip. I'll try that and let you know how it works.

It must be a localized issue, as I've just completed a sysupgrade of my TP-Link C2600v1.1 to 18.06.2, all working as expected!

The 'shadow file' suggestion that @trendy put forward seems worth a try!

Hope you can sort yours out, Good Luck :wink:

Thanks otnert!

Unfortunately, the "shadow file" suggestion did not work. It was interesting though. When I entered the password I did not receive an "invalid username / password" message. The screen just popped back to the home screen. On other attempts, I always received the invalid username / password message.

I am at 18.06.1 now, and it works. I prefer not to have to rebuild my system: I rather restore settings but I guess I've got no choice at this point. :frowning_face:

Yeah, it gets tiring when things don't work according to plan :confused:

I wonder if it may be a browser issue, have you tried using a different browser?
I used Firefox Quantum (portable edition).

I take it you were performing a sysupgrade with the 'Keep settings:' check box ticked, to 18.06.2.

The only other suggestion I have is to:

  1. Create a backup of your working 18.06.1, and create a list of all installed packages
  2. Sysupgrade to 18.06.2 by unselecting the 'Keep settings:' check box
  3. Once up and running create a clean 18.06.2 backup
  4. Restore your working 18.06.1 backup
  5. Re-install any additional packages

Yes, I use Firefox Quantem, latest version.

And yes, I did do a sysupgrade with the "keep settings" tick box checked.

There is something very strange happening with my system. My old network was Of course the default is for OpenWRT when installing new. Since I have been trying to reset everything and do a complete new install, I have not been successful changing the lan network to

I am feeling pretty stupid at this point, really. I changed the lan interface and ensure it is set to static and still, when I reboot the router, and reload my nic, my IP is showing, even though the luci settings clearly have the lan set to, as a static address.

What to do?? Anyway, I will figure this out even if I have to go back to factory settings!!

It's up to you, follow the steps that I suggested, which will create a clean slate install to work with.

Thanks to you I was able to ssh into my system and get back up and running. However, I can't logon using luci / webif. Any ideas??

ok, I am back in business!! I ssh'd and updated packages after reinstalling 18.06.2. I updated packages list, checked "list-upgradable, and id'd which ones needed updating. I basically reinstalled luci and now I'm good to go. Not sure which package was giving the problem logging on with luci, but it appears to be one of the luci libraries.

Anyway, thanks for your help!

1 Like

Do not update packages. Only install those not included in the firmware.


Great!:smiley: good news!

However as @lleachii stated, don't continue to upgrade packages, only re-install the missing packages otherwise you might end up in the same boat as in your first post!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.