Help to unbrick Archer C2 Ac750 v1.1 EU

Good Morning. I need help to debrick Archer C2 v1.1 EU. I need to know which USB-Serial adapter I need to purchase, how to create the recovery image, how to connect the adapter to the board and which commands to give. That is, a complete guide. I looked on the forum and on the website but I had more questions than answers. Please I need help. Thank you!

Did you look at the ToH for your model? There are pictures which could help you locate the serial connection (J2), at least. Here it is:
https://openwrt.org/toh/tp-link/archer_c2_ac750

As for the commands, once you get serial access they are listed in the following archived OpenWrt thread:
https://forum.archive.openwrt.org/viewtopic.php?id=52625&p=2 ==> See post #41 and 42

First thing first: Have you already tried the TFTP recovery method and failed at it?

EDIT: I'll answer myself:

TFTP don't work. No IP address, only power led.

I did not understand the procedure very well. I will not risk buying a serial cable and fail to pass the correct commands. When using this, I will buy a tool to record the eprom. But I also didn't understand how to create the bin file to restore the original firmware. So I can't use the manufacturer's original fiemware without changes. Can you help me?

The TFTP client lives in the bootloader. If you bricked your bootloader, a USB-Serial adapter won't help you. In that case JTAG is the way to go.

Give TFTP another shot. Yes, you can also use the manufacturer's original firmware image. Just make sure you have the correct one.

  1. Download TFTPD64
  2. Connect your archer directly to your computer via an ethernet cable. You should connect the LAN1 port to your computer.
  3. Set a static IP address on your computers network interface. It should be set to to 192.168.0.66 with netmask 255.255.255.0. Leave the gateway and DNS options empty. See here for an explanation.
  4. Start TFTPD64 and set the Current Directory to a folder that contains the factory original image. The factory original image should be named ArcherC2V1_tp_recovery.bin.
  5. Set the server interface to your network adapter.
  6. Continue with the steps from the OpenWRT TOH. Copied from the TOH: Connect your device to the LAN port, then press the WPS/Reset button and power it up. Keep pressing the WPS/Reset button for 10 seconds
  7. The device will try to download the recovery image and flash it. This might take up to 20-25 minutes to finish. When done, the router will reboot itself.

Now your back on the factory image. Doesn't this work? Check the following points:

  1. TFTPD64 should show a log - if nothing appears in the log, try to set your static IP to 192.168.1.66. I've the IP address depends on the firmware revision.
  2. If you something in the logs, but your router doesn't fetch the file, make sure the filename of the factory image is correct. TFTPD64 should tell you what file (and therefore the filename) it's trying to fetch.

If it's not working at all - we can do a teamviewer session.

The router gives no sign of life beyond the power led, does not associate an IP address, so TFTP never starts the installation. I corrupted the router's bootloader. If I download the original firmware, remove the 512-byte header, will I be able to rewrite the eprom with this image?

I buy this https://www.eletrodex.com.br/gravador-usb-flash-eprom-series-24xx-e-25xx-clip-adaptador.html

How did you corrupt the bootloader? That stuff usually require writing manually to the eeprom, and is not recommended anywhere during the installation of OpenWRT normally.

And it's right - it doesn't associate an IP address. That's why you have to set a static one.

I have tried to manually associate an IP address. The router does nothing, gives no signal.

I think I corrupted the bootloader when trying to restore the original firmware via TFTP. I had installed OpenWRT via TFTP, following the instructions. I didn't like the performance and decided to come back with the original firmware but I didn't realize that I couldn't just take the original firmware and install it with TFTP. Thus, I believe that the original firmware overwrote the router's boot.

In that case, before going nuclear with JTAG or a eeprom flasher (if you can find some points to connect..) you should try a USB-TTL converter to see whats going on during boot. Every USB TTL with 3.3V and 5V support should do the job. I have a FTDI FT232RL based one, but there are some newer version out there using newer chip. Those are just 1.50 euros from your favorite china shop.

Also please note the following comments from the TOH:

If you encounter timeouts, you might want to put a switch between your router and client to facilitate the flashing process. The tips below might not be needed after that.

A few users reported that flashing via TFTP server was only possible when the option “Use anticipation window of” with 1000 bytes was enabled in TFTPD32 for Windows. So, if your flashing process hang at some point, restart the process with this option enabled.

Also, you might have to lower your ethernet link to 10 Mbps Half Duplex in order to finish the process.