Help To Override IPv6 DNS Servers in Relay Mode

I am attempting to override my IPv6 DNS servers but with no luck, the clients get no IPv6 DNS set at all, its worth pointing out that my ISP only provides the WAN /64 address with no prefix (so i am using relay mode), and they do not supply any auto configured DNS servers

The clients get the IPv6 address correctly and can ping out on IPv6 addresses

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbe:2c80:9f9b::/48'
	option packet_steering '2'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth2'

config device
	option name 'eth0'
	option macaddr '2e:62:ca:ad:86:f6'

config device
	option name 'eth2'
	option macaddr '2e:62:ca:ad:86:f6'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth1'
	option macaddr '2e:62:ca:ad:86:f5'

config interface 'wan'
	option device 'eth1.911'
	option proto 'dhcp'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan6'
	option device 'eth1.911'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '60'
	option peerdns '0'
	list dns '2606:4700:4700::1111'
	list dns '2606:4700:4700::1001'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '911'
	option name 'eth1.911'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '0'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option ednspacket_max '1232'
	option port '53'
	list server '192.168.1.1#56'
	option noresolv '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

ifstatus wan6

{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 40092,
	"l3_device": "eth1.911",
	"proto": "dhcpv6",
	"device": "eth1.911",
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2a11:2c80:2002:42:2c62:caff:fead:86f5",
			"mask": 64,
			"preferred": 604774,
			"valid": 2591974
		}
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "2a11:2c80:2002:42::",
			"mask": 64,
			"nexthop": "::",
			"metric": 256,
			"valid": 2591974,
			"source": "::/0"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::d66d:50ff:fe2d:b9b6",
			"metric": 512,
			"valid": 1774,
			"source": "2a11:2c80:2002:42:2c62:caff:fead:86f5/64"
		}
	],
	"dns-server": [
		"2606:4700:4700::1111",
		"2606:4700:4700::1001"
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		
	}
}

I have also tried adding the servers to the dns section in the dhcp config for lan, but with no success.

Andy advice would be appreciated