Help! SQM not loading after restart

Hello Everyone! I'm new here! I have a problem with the SQM loading after a router restart. I have to go into the Software and manual restart it to get it to work. I have added /etc/init.d/sqm restart to the local.rc file but it doesn't work.

did you try adding a sleep 60 before doing the restart ?

or did you perhaps add it after the exit line ?

You set this to '1' in cli and save then when you reboot it is '0' ?

Is it just add Sleep 60 or do you add it too /etc/init.d/sqm restart (ex." /etc/init.d/sqm restart sleep 60"). I'm a novice please be patient and explain.

Do I just append what you type after /etc/init.d/sqm restart ? could you please type out the sample code? Thank you for your help and patience.

sleep 60
/etc/init.d/sqm restart 
exit 0

the exit is already there.

reboot and this what I got
image

No luck still doesn't load the SQM

Well, that's very wrong...

What did I mess up I installed SQM scripts, sqm extra scripts luci sqm interface and only added my bandwidth for the ingress and egress??

You were told what rc.local should contain, it doesn't.

You're also editing the wrong file, something I missed in your 1st post.

ok that is the file I was told to edit by the support team at GLinet. Do you mind walking me through the process?

If you're using gl Inets firmware, we have no idea.


It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Yep not supported, but thanks so much for your help! Enjoy your weekend fam

Just flash it to OpenWrt. The router is fully supported in OpenWrt.

edit:
I could have sworn I read you have a GL-MT3000 but I do not see that anymore.
What router do you have?