Help setup igmpproxy archer A7 V5

Hello everyone, I've been trying to setup igmpproxy,

In TP Archer A7 V5, stock software, I only left default IGMPproxy and set version v2, and it works. I want to replicate this config in openwrt.

I followed this guide https://openwrt.org/docs/guide-user/network/wan/udp_multicast

but it doesn't seem to work.

Current igmpproxy settings.

/etc/config/network      

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4a:ed20:4d30::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'd8:07:b6:80:77:f9'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'


/etc/config/igmpproxy
config igmpproxy
        option quickleave 1
#       option verbose [0-3](none, minimal[default], more, maximum)

config phyint
        option network wan
        option zone wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option zone lan
        option direction downstream

Any help greatly appreciated.

Disclaimer: I'm not using igmpproxy, but your network configuration doesn't seem right.

Make the device and interface sections look like this and restart the network service to see if it makes a difference.

#/etc/config/network

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
	    option igmp_snooping '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

I'm glad to receive your help, I already set up the network configuration, but it still doesn't work

Have you tried quickleave 0?

Hello eachi, yes I tried, but getting the same results