Help setting up LAN and two VLAN's over same adapter (mvebu + DSA)

Not sure where 21.x is at with commits, what about:

bridge vlan
brctl show

Bridge seems not to be included.

root@OpenWrt:/etc/config# bridge vlan
-ash: bridge: not found
root@OpenWrt:/etc/config# brctl show
bridge name	bridge id		STP enabled	interfaces
switch0		7fff.d263b41a53d6	no		eth2
root@OpenWrt:/etc/config#

EDIT: One thing I am doing in the meantime, I am going through my switches once more and changing all ports to "tagged" for VLAN traffic over 2 and 3. They were set to "untagged" prior.

You will probably want to add that to your build:

Summary
root@mamba:/# bridge vlan
port              vlan-id  
lan4              10 PVID Egress Untagged
lan3              10 PVID Egress Untagged
lan2              20
                  30
                  4094 PVID
lan1              20
                  30 PVID Egress Untagged
itch0             10
                  20
                  30
                  4094
wlan0             10 PVID Egress Untagged
wiot0             30 PVID Egress Untagged
wlan1             10 PVID Egress Untagged
wiot1             30 PVID Egress Untagged

1 Like

Adding it now and will do a recompile and we can pickup from there. Thanks @anomeome , you've always been good to me :slight_smile:

Okay, so I'm a dumbass :slight_smile: I think the fact that my switches had the ports set to VLAN 2 and 3 as "untagged" prevented the tagged traffic from flowing. Once I changed them to "tagged" ports for 2 and 3, magic happened.

Here is my config at the moment, which seems to be working as expected, dhcp and all:

config device
	option type 'bridge'
	option name 'switch0'
	list ports 'eth2'

config bridge-vlan
	option device 'switch0'
	option vlan '1'
	list ports 'eth2:u*'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'switch0.1'
	option ipaddr '192.168.1.1'

config bridge-vlan
	option device 'switch0'
	option vlan '2'
	list ports 'eth2:t'

config interface 'guest'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'switch0.2'
	option ipaddr '192.168.2.1'

config bridge-vlan
	option device 'switch0'
	option vlan '3'
	list ports 'eth2:t'

config interface 'iot'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'switch0.3'
	option ipaddr '192.168.3.1'

I am not sure if eth2 on VLAN1 really needs to be called out as untagged and primary :u* but I will leave it for now. Thanks @anomeome

Also @jow , I am not sure if it's expected or not, but I also noticed something strange when it comes to the VLAN's we added by hand. What I mean is that if I go into /etc/config/network and add by hand:

config bridge-vlan
	option device 'switch0'
	option vlan '3'
	list ports 'eth2:t'

config interface 'iot'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option device 'switch0.3'
	option ipaddr '192.168.3.1''

Then issue /etc/init.d/network restart, I can go into luci and look at Network->Interfaces->Devices and my VLAN(s) appear as expected:

BUT, if I click the "configure" button next to one of the newly created (greyed out) VLAN's and make 0 changes BUT I do click "Save", then 2 pending changes appear:

At that point my greyed out VLAN definition becomes a defined "Device" in the devices list, no longer called out as "VLAN (802.1q)". I am not sure if that is expected behavior or not?

1 Like

@anomeome what package contains the bridge command? I added "bridge" under "Base System" but that wasn't it.

Search of ip-bridge should find ti.

1 Like
root@OpenWrt:~# bridge vlan
port              vlan-id  
eth2              1 PVID Egress Untagged
                  2
                  3
switch0           1
                  2
                  3

Kind of expected, not a reason of concern at least and no effect on the underlying configuration.

@jow did you see these two items as well? (the replied to post) There is a typo on Bridge VLAN Filtering page as well on the same page LUCI is not properly showing the flags set for a given port.

Will fix the former, could not reproduce the latter this morning.

Is there anything I can provide you to help with it? It's very persistent on my system and survives reboots as well as system upgrades (21.02 branch). I am current as of this morning on that branch.

You could PM me your complete /etc/config/network. Also maybe try the fix https://github.com/openwrt/luci/commit/f6f1eacb012b0364940c1dc9b9392fc0e60405b9 which I pushed to master this morning. Will backport it to openwrt-21.02 along with other fixes within the next few days.

Edit: ah, I think I found the mistake. I couldn't reproduce it because my ifnames are called lan1..lan4, wan, none of them contains a t :wink:

1 Like

EDIT: Okay, cool! I will hang back then :slight_smile:

Fixes pushed.

1 Like

Thanks @jow , quick turn around. Will you push also to 21.02, that's where I am currently building. Or you think it's okay if I cherry pick?

You should be able to cleanly cherry pick those two commits (in the same order as written above). I'll do another backport round for openwrt-21.02 in the next days, but I want to wait for LuCI master to settle first.

1 Like

You da man, thanks!

We are close, but I notice one more thing that it seems to be missing (untagged vs tagged works now, thanks!):

The u* I believe represents both "untagged" as well as "Primary VLAN". When looking in Luci, it is not seeing that this VLAN ID is also marked as the "Primary VLAN".

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.