Help setting up Dumb AP on OpenWrt 21.02

Hi, I'm currently running 19.07 and wanted to upgrade to 21.02, while doing that i had trouble setting up my WRT1900ACS as a DumpAP so I had to revert back.
All I need is to have all of my 4 interfaces talk to each other and also have 2 wireless radio (2.4+5) another router is handling the DHCP of course.
I tried to follow the guide but it seems like it is not applicable to the new version.
This is my network configuration today:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd59:5546:51e3::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '10.10.10.1'
	option ipaddr '10.10.10.2'
	list dns '10.10.10.10'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '5t 3 2 1 0 4'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t'
	option vid '2'

When you upgrade to 21.02 you should not keep the settings. There are a lot of changes in the configuration files and the network config from 19.07 is not compatible with 21.02.
In a nutshell 21.02 is using DSA instead of swconfig, therefore you'll need to fix the universal bridge from the beginning.

if your device has DSA enabled this may be of interest
it works on my MT76 2102 devices
paste this into you ssh sesion
& then you will have to find the IP it's been given

uci del network.cfg030f15.ports
uci add_list network.cfg030f15.ports='lan1'
uci add_list network.cfg030f15.ports='lan2'
uci add_list network.cfg030f15.ports='lan3'
uci add_list network.cfg030f15.ports='lan4'
uci add_list network.cfg030f15.ports='wan'

uci set network.lan.proto="dhcp"
uci set network.lan.ipaddr=""
uci set network.lan.netmask=""
uci del network.lan.ip6assign
uci set network.lan.delegate='0'
uci del network.wan
uci del network.wan6
uci set network.lan6=interface
uci set network.lan6.proto='dhcpv6'
uci set network.lan6.ifname='@lan'
uci set network.lan6.reqaddress='try'
uci set network.lan6.reqprefix='no'
uci commit network

uci del firewall.cfg02dc81.network
uci set firewall.cfg02dc81.network='lan lan6'
uci commit firewall

/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop

uci del dhcp.lan
uci del dhcp.wan
uci del dhcp.odhcpd
uci commit dhcp

/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop
2 Likes

This worked perfectly, thank you so much