Help required to revert to stock TP-Link Archer C7 V4 EU


I have an Archer C7 V4 EU that has OpenWrt SNAPSHOT r7559-3ee2c76 / LuCI Master (git-18.207.24066-5c07c6f) installed.

The truth is I got here from a bricked Router and would like to revert back to stock EU firmware, however, I have read about stripped firmware etc and I am completely lost.

First of all is it possible and secondly is there a dummies guide anywhere that someone can point me to. I managed to get the router alive again via TFTPD and flashing the factory and sysupgrade images, I've also got Luci installed.

If it's not possible to flash back to stock, is there a way I can turn the router into an access point?

Finally I am really a Newby so any help is much appreciated


This usually means you have to remove the first few bites of a stock firmware to make it successfully flash. I'm not sure about how to do this for your particular device.

This should be possible. In the most basic setup for an AP, you just reconfigure the router's LAN to have an IP and DNS server. You then setup the SSIDs as desired.

Thanks, I have seen the stripped firmware but couldn't find any instructions on how to do it. However if I can configure the router as an AP, assuming I just disable DHCP etc then I can at least use it.

There are plenty of posts saying you can revert to stock but I haven't found anyone who has done it for this model.


I have tried this and it doesn't work for my C7 V4 eu model. I've taken the stock file, renamed it etc and it doesn't work.

I did use this process to flash OpenWRT factory and sysugrade and that's how I got it working again on OpenWRT.

this revert to stock using the TFTP method does not work with C7 v5 either...

Obtain the factory firmware from the OEM:

  • UNTESTED in case the file name of this firmware file does not contain the word "boot" in it, you can simply revert back to original firmware

  • in case the file name of this firmware file does contain the word "boot" in it, you need to cut off parts of the image file before flashing it:

An example of an image file with the word "boot" in it is ArcherC7v1_en_3_13_33_up_boot(130729).bin .

Cut the first 0x20200 (that is 131,584 = 257*512) Bytes from original firmware (not sure why 0x20200, as the bootloader partition is only 0x20000, but it works!):

dd if=orig.bin of=tplink.bin skip=257 bs=512

You should transfer the firmware image to the /tmp folder and revert back to original firmware (if available you can flash the firmware via the webinterface as well):

Via the safer method using sysupgrade:

sysupgrade /tmp/tplink.bin

Or alternatively you can use the mtd method:

mtd -r write /tmp/tplink.bin firmware

TFTP Recovery (De-Bricking)

The serial-less TFTP recovery method for the TP-Link TL-WDR4300 also works for the Archer C7 (confirmed on v1.1 and v2) and the Archer C5 (v1.20).

For firmware revisions before 3.14.1 (140929), the router looks for an IP address of and a file named ArcherC7v2_tp_recovery.bin . Firmware 3.14.1 updates the bootloader to look for an IP address of and a file named ArcherC7v3_tp_recovery.bin even on hardware v2 units. Some v1.1 units may also look for ArcherC7v1_tp_recovery.bin . The model Archer C5 looks for the file ArcherC5v1_tp_recovery.bin .

To activate TFTP Recovery press and hold WPS/Reset Button during powering on until WPS LED turns on. Setup your computer to (SubnetMask /24 = and connect it to LAN1. Start TFTP server and provide recovery file with it.

For de-bricking with an OpenWrt image use the factory.bin image. :!: In case you are flashing back original firmware, make sure original firmware image name does not contain word bootreturn_to_factory_firmware.

TFTP de-brick Alternative

  1. Use the Cut file above and rename it ArcherC7v2_tp_recovery.bin

  2. Change your Ethernet adapter to IP, subnet, gateway

  3. Download Tftpd32 by Ph. Jounin at

  4. Browse to the directory that hold ArcherC7v2_tp_recovery.bin file.

  5. Choose for your "server interfaces"

  6. Choose Tftp server tap

  7. Activate TFTP Recovery press and hold WPS/Reset Button during powering on

1 Like

There is a 512 byte header in front of the individual firmware components (mtds).

I'll just share this Archer C7 V4 RU recovery recipe here:

  1. Setup ethernet adapter to use IP mask gateway
  2. Use tftpd32 (32Bit exactly as stated), in global settings leave only TFTP Server running, verify that it's listening on port 69 in cmd with netstat by typing:
    netstat -an 3 | find "66:69"
  3. Use Archer C7(RU)_V4_171130.bin, rename to ArcherC7v4_tp_recovery.bin and place to tftpd32 shared folder
  4. Connect ethernet cable to ethernet port 1 on the router
  5. While holding recessed "Reset" button (not the WPS/Wi-Fi!) press "Power" button and wait until data transfer LED lights up (Two arrows pointing different directions).

If everything went right - you will see "Read request for file <ArcherC7v4_tp_recovery.bin>. in tftpd log window. The flash operation took me about 3 to 5 minutes.

1 Like

Thanks for the tutorial, I finally have stock firmware loaded on my archer c7 v4. I spent hours mucking around with tftp without success and then I disabled windows firewall and voila!

Hello cv05, I'm still trying to back to stock fw, but no lucky until now. I'm flash LEDE, and i can ping the router in
I Flashed using tftpd, define my network card as
But I don't know why, I can't flash the stock fw yet. I'm trying 3 differents fw.. but nothing.
Using tftp-hpa in Ubuntu, and used wireshark to see router requests, and seems fine.
Any idea? Which rom did you used?
thanks in advance.
I noticed that I can flash ANY openwrt firmware without problem.. Just stock firmware I can't. I'll keep trying. thanks

Did you try stripping the factory firmware and flashing the same through tftp?

I have tried to restore the factory firmware on my Archer C7 V4 EU.

I have tried all versions available for download on the tp-link website (180315, 180425 and 190411). I am using a Mac so I have used the recipe on the OpenWrt website. Also tried with the program PumpKin.

The problem is that the firmware from TP-Link is much larger and the TFTP transfer stops prematurely before the whole image is transferred. Flashing an OpenWrt image works without problem. So I am stuck at OpenWrt at the moment.

Any suggestions from anybody?