Help required: setting up OpenWrt as dumb AP via luci

I am trying to setup a dumb ap via luci on the latest release of OpenWRT (21.02.0) by following the docs on https://openwrt.org/docs/guide-user/network/wifi/dumbap.

Unfortunately things are not very clear. It seems that some things may have changed with this release of OpenWRT. I managed to brick and unbrick my WNDR3800 four times in trying to follow the instructions and fudging when things were not clear.

Here are the current issues:

  1. where it says "3. Enter an IP address “next to” your main router on the field “IPv4 address”. (If your main router has IP 192.168.1.1, enter 192.168.1.2). Set DNS and gateway to point into your main router to enable internet access for the dumb AP itself":

If I use 192.168.1.1 to point into my main router it complains about it being not able to be a local ip address. Secondly, there is no DNS box on the page.

  1. where it says "6. Under “Physical Settings” tab, ensure “Bridge interfaces” is ticked, and ensure BOTH of your interfaces (eth0, wlan0) are selected, in order to allow traffic between wireless and wired connections.",

the wlan0 does not show and thus is unable to be ticked. It only show eth0 and eth1 (WAN, WAN6) but no wlan0!

Could anyone point me in the correct way to go about this.

Thanks for any help.

After you enter 192.168.1.2 click save and apply, then open a new tab and go to 192.168.1.2, then you should be able to enter 192.168.1.1 to point to your main router

DNS should be in the Advanced Settings tab of lan interface

Those are just examples, your interfaces will probably be bridged by default, so you shouldn't need to change anything there

Hello Mike,

Thank you very much for your prompt reply.
I did follow your instructions, and it all seemed to have gone OK until I tried it out.
The situation now, is that I when I set the gateway to LAN and a computer to LAN, the computer connects and receives the correct IP address (I use a static one based on the MAC address) from the gateway router.
The gateway router has firewall rules that allows all LAN to all WAN, but my browser gets a "No Internet" page and neither can I ping the gateway.
So the issue does not seem to be dns but still a routing in the dumb ap?
I can ping the dumb ap from a computer connected to it and from the gateway router. I can also ping a computer connected to the dumb ap from the gateway router.

Try rebooting your gateway router and then rebooting your dumb ap.

what's the dumb AP device, and show your network and wireless configs

Mike and Jaromanda,

Thanks a lot for trying to help.

I now believe that this issue is a DNS related one but upstream from the dumb ap.

Again, thanks for your time and interest.

I just setup my AP this morning and I used these instructions: https://openwrt.org/docs/guide-user/network/openwrt_as_clientdevice

On AP's LAN interface I changed it to a static IP 192.168.1.5 (main router is 192.168.1.1) On AP set
netmask 255.255.255.0, gateway 192.168.1.1. Make sure your main router's DHCP range on 192.168.1.0/24 doesn't cover the static IP address for your AP. The default is to make 192.168.1.100 the lowest addr served by DHCP, so if you didn't change this on your main router you should be good.

Then switch to the Advanced Settings tab and make sure Use Default Gateway is checked and enter 192.168.1.1 in Use Custom DNS Servers

Finally switch to the DHCP Server tab and check Ignore Interface to disable DHCP in the AP's LAN interface.

I made one other change so my AP would retrieve time via NTP. Under System->System->Time Synchronization I unchecked Use DHCP advertised servers. I suppose I could have made my router an NTP server and then pointed the AP at the router for NTP but this was the easiest.