[Help Request] - ImageBuilder not producing *_factory.bin?

Hello folks,

So, TL;DR: I have an Iomega ix2-200 that I'm installing/have installed OpenWRT on.
This has been in the pipeline of projects to tackle since a long time and I just had some time over the holidays to research, install and test everything.

In this sequence, I eventually ended up on mikeym88/openwrt-nas-script and I'm essentially building my own image with Imagebuilder now.

Now, I've come to a stage where I'm running the following make image command:

make image \
  PROFILE="iom_ix2-200" \
  FILES="files" \
  DISABLED_SERVICES="dnsmasq odhcpd" \

However, this is producing an error on the outputs and is also not producing the *_factory.bin binary to flash the NAS with, it's just generating the *_sysupgrade.bin binary.

bash: line 1: 8: Bad file descriptor
cp: cannot stat '/home/ubuntu/openwrt-imagebuilder-22.03.2-kirkwood.Linux-x86_64/build_dir/target-arm_xscale_musl_eabi/linux-kirkwood/tmp/openwrt-22.03.2-kirkwood-iom_ix2-200-squashfs-factory.bin': No such file or directory
Skip JSON creation for non existing file /home/ubuntu/openwrt-imagebuilder-22.03.2-kirkwood.Linux-x86_64/build_dir/target-arm_xscale_musl_eabi/linux-kirkwood/tmp/openwrt-22.03.2-kirkwood-iom_ix2-200-squashfs-factory.bin

Calculating checksums...

ubuntu@ubuntu:~/openwrt-imagebuilder-22.03.2-kirkwood.Linux-x86_64$ ll bin/targets/kirkwood/generic/
total 33872
drwxrwxr-x 2 ubuntu ubuntu     4096 Dec 28 20:47 ./
drwxrwxr-x 3 ubuntu ubuntu     4096 Dec 28 17:45 ../
-rw-rw-r-- 1 ubuntu ubuntu 34652946 Dec 28 20:47 openwrt-22.03.2-kirkwood-iom_ix2-200-squashfs-sysupgrade.bin
-rw-rw-r-- 1 ubuntu ubuntu     6861 Dec 28 20:47 openwrt-22.03.2-kirkwood-iom_ix2-200.manifest
-rw-rw-r-- 1 ubuntu ubuntu     1100 Dec 28 20:47 profiles.json
-rw-rw-r-- 1 ubuntu ubuntu      319 Dec 28 20:47 sha256sums

Can you help me? What I'm doing wrong? Why can't I create the factory binary?

Also, is there a way to execute a script only once on the NAS/OpenWRT when it first boots or something? I wanted to execute a slightly different version of the linked repo's initial_setup.sh scripts

Happy holidays everyone

Anyone, please, could help me out?
I'm still stuck. I've tried adding the file manually to the directory and everything, but once the build restarts, looks like it gets deleted and them we're back to the same error..

Where could I even start looking for a solution? I don't see anything extraordinary in the logs..