Help regarding roaming setup between 2 dumb APs

I've been trying to make my setup work for a couple of months now.
I've created a small "fast roaming" scenario, where 2 openwrt routers are set to dumb AP, and they're all connected to another openwrt router which handles DHCP, SQM QoS and whatnot.

The APs share the same network SSID and credentials, and both are configured to utilize the 802.11r fast roaming feature, with FT over the AIR as the only setting I changed from stock.

The whole wireless setup seems to work properly with many devices I own (all my laptops do roam from an AP to the other, in a seamless way). Even wife's iPhone do switch properly, without connection loss.

The real deal comes when I try to use my android devices. None of them does roam properly. The behaviour is quite strange, as the devices will eventually disconnect from the network and after a couple of seconds will try to connect to the nearest AP (which is not wrong, actually), resulting in a successful connection but without being able to ping other devices and without internet connectivity.
There's never a proper switch from one AP to the other without disconnecting from the main WiFi.
This is quite annoying since it happens every time I walk from my bedroom to the living room, from one AP to the other, but they're not that far apart. This breaks push notifications and whatnot, since the device does not have internet access but is in fact connected to the WiFi.
Toggling airplane mode on and off does solve the issue, but that's more than frustrating.

Since I had no luck with 802.11r I'm trying to find other solutions which can solve this issue, or even better, other ways to seamlessly merge my WiFi into one, beside the device I'm using.
I only want to roam between 5Ghz WiFi signals.

Funny, I have the exact same issue. Was thinking about flashing my Android device with a custom ROM to check if it is an issue of the vendor's Android version.. but since there is sensitive data on that device, I hesitate to do it.

1 Like

I wonder if they are getting tripped up by 802.11r. Not all devices support the standard, and some behave poorly.

Roaming doesn't require the use of 802.11r or other similar standards. Simply configuring your APs appropriately is all it takes to make a nearly-seamless roaming setup. Roaming is actually a client side process, so you want to help encourage the clients to roam by optimizing your configuration.

It is critical that you tune the power levels of the APs (i.e. reduce the power) such that the coverage overlap between neighboring APs is as small as is reasonably possible. This makes it more likely that the devices will roam to the nearest AP rather than hanging on to one that is farther away. The other requirement is that the channels must not overlap on neighboring APs.

I like this video for describing the process of optimizing wifi. Although it deals with Unifi, it is applicable to all wifi systems (as long as the controls are exposed to the user).

If you want this, you need to do one of two things:

  1. disable the 2.4GHz radios
  2. use a unique SSID for the 5GHz network so that the client devices cannot use the 2.4GHz link.

Keep in mind that 5GHz does not penetrate through walls and other obstacles as well as 2.4GHz signals... as a result, the 5GHz radio performance will likely drop more rapidly as you move around your space. The practical consideration here is that the performance on 5GHz may actually be worse than at 2.4GHz in some situations, so you may be setting yourself up for a less performant scenario if you restrict the devices to 5GHz.

1 Like

I recently came back to this topic as I was setting up a new home network.
I got myself a pair of Archer C6 v2 with the latest openwrt stable build (21.02.2)

Funny enough, now fast roaming seems to work just fine. None of my mobile devices got any update in the meantime. The only thing that changed were my routers: I left the two AC2100 from Xiaomi at my previous house in favor of the TpLink ones.

The only thing I miss is the wireless speed: I have gigabit internet now and such router struggles with Wi-Fi throughout (oddly enough it does 540 mbps with iperf3). Realistically, I only get around 270 mbps since the single core gets obliterated by some workload I have yet to discover; I run the tplink routers in dumb AP mode.