Help recovering bricked Xiaomi Mi Wifi Mini V1

Good day everyone. I hope you guys can help despite your tight schedule. I flashed the official english rom on my device while trying to revert from openwrt 19.07 given the unstable wifi. Unfortunately, the device is stuck in a boot loop and the ports (lan and wan) keep flashing. I've tried the following but unsuccessful:

  1. Recovery via USB formatted FAT32 and stock rom renamed to miwifi.bin

  2. Using Arduino for Serial connection, i tried to interrupt the boot sequence so as to get into the first option (Load system code to SDRAM via TFTP), unfortunately, that failed as well. I later learnt the boot loader is locked and such interrupts are not allowed. I have pasted the boot-logs from the serial connection.

U-Boot 1.1.3 (Jan 28 2016 - 18:16:3▒)

Board: Rali▒k A▒SoC▒DR▒M:  128 MB
Power on mem▒▒▒ test. Memory size= 128 MB...OK!
reloc▒te_code Pointer a▒▒▒68000
enable ephy ▒▒▒▒▒..done. rf reg 29 = 5
SSC disabled.
Software System Reset Occurred
spi_wait_nsec: 29
spi device id▒▒▒栴0 18 0 0 (40180000)
find flash: W25Q128BV
ra▒▒▒▒▒▒ad: from:30000 len:1000
raspi▒▒▒▒▒ from:30000 len:1000
Ralink UBoot Version▒▒▒▒▒▒S.1
                                             ▒▒▒▒à7620_MP (Port5<->None)
DRAM component: 1024 Mbits D▒Ҭ▒▒▒dth 16
DRAM bus: 16 bit
Total memory: 128 MBytes
                        ▒▒▒▒▒▒ component: SPI Flash
Date:Jan 28 2016  Time:18:16:▒▒▒▒▒▒==========================================
icache▒▒▒▒▒▒:512, ways:4, linesz:32 ,total:65536
dcache: sets:2▒▒▒▒▒▒ys:4, linesz:32 ,total:32768

 ##### The CPU fre񠽠▒▒0 MHZ ####
 estimate memory size =128 Mbytes

Please choose the operation:
   1: ▒▒▒▒system code to SDRAM via TFTP.
   2: Load system c▒▒▒▒▒en write to Flash via TFTP.
   3: Boot system code▒▒▒▒▒lash (default).
   7: Load Boot Loader code then write to Flash via▒▒▒▒▒▒l.
   9: Load Boot Loader code then write to Flas▒▒▒▒TFTP.

3: System Boot system code via Flash.▒▒▒▒▒to boot Recovery System
raspi_read: from:3000▒▒▒▒▒10000
Erasing SPI Flash...
raspi_erase: offs▒▒▒▒▒▒ len:10000
Writing to SPI Flash...
r▒▒▒▒▒▒rite: to:30000 len:10000
## Booting▒▒▒▒▒▒ at bccd0000 ...
raspi_read: from:cd0000 len:40
▒▒▒▒▒gic Number,A24F2BCB, try to reboot
raspi_read: fr▒▒▒▒00 len:10000
Erasing SPI Flash▒▒▒▒▒▒aspi_erase: offs:30000 len:10000
Writing to SPI Flash...
▒▒▒▒▒▒write: to:30000 len:10000

I will be grateful for all the inputs and suggestions. Thanks