Help Please installation nightmare!

I had my router up and working wonderfully with NordVPN on it. I wanted to change servers so I downloaded nordvpnrouternanager and it has screwed my router up. I have restored it to the point of being able to login as in Luci. It will not allow me to change that IP address by selecting the Lan and doing so by ipv4. I have set up the WiFi channels and they show up on available networks but I have no internet. I also can not upload the new packages or updates because I have no internet. I have spent 7 hours on this and I can not figure out what I’m missing. When I go to change the IP address it just gives me the rollback message. I also can not ssh in to the router so I have to do whatever suggested via luci interface. Some one please save me from this nightmare! Thanks so much!!

@Tvthings1, welcome to the community!

Did you hit the big red "Apply Unchecked" button?

Do you need to clear the old key?

That can occur when your upstream network and OpenWrt LAN have the same IP scheme. This is likely so, given the fact that you wish to change it.


For changing your router's LAN IP to an IP on a different subnet, there is the Apply Unchecked way that @lleachii mentioned , and some other options. Further reading here


I did hit apply unchecked and still got the rollback message. When you say erase the old key for ssh what do you mean? I apologize I’m totally ignorant to all of this. I have read and read and a lot of this goes over my head. It was a miracle I got it to work the first time. I’m so mad and frustrated.

It should work. But you can always try one of the other methods in the link I provided earlier.


You can do it also like this:


I can get the WiFi to set up. However when I go to connect to the WiFi I have no internet. How do I fix this. I also can not putty or ssh into this router. I am trying to set this router up as a vpn router going through my main router.

I think you need to go step by step, change one thing at a time to see where things go wrong.

Did you mange to change the IP? What's your main router's IP, and how are they connected? By a cable, LAN to WAN?


Ok here is what I’ve done so far I have my spectrum router which is hooked up to my modem hooked up to the tp link router. I have set up and connected the WiFi networks. I have changed the up address to I can access my router now with out the Ethernet. What I can not do is access internet. I have no internet connection? I think maybe I am suppose to bridge them some how? But I do not n ow how. Also, when I try to download software under system it does say check network connections.

Main router up is

Plug an Ethernet cable from one of the main router's LAN ports to the OpenWrt router's WAN port.

I have that connected already.

On the Status->Overview page, do you see IPV4 Upstream with a 192.168.1.X address from the main router?

Well actually there is no ipv4 upstream. I do have ipv6 upstream and under network there are no active dhcp leases. Also no active connections.

In the default configuration, network 'wan' is an IPv4 DHCP client, thus it should acquire an IPv4 address from the network on the WAN port, which is your main router.

It may be a good idea to reset fully to a default configuration and configure from there, to avoid having previous mis-configurations haunt you.

Okay. I am doing a perform reset now. When I did the reset and looked under overview there is no ipv4 upstream there. What should I do?

I actually reflashed it with the firmware just now. Maybe this will help! I’m so lost as to what to do.

What model router and what OpenWrt version?


OK now you need to change the LAN IP to, for example,

Ok I’m working with an tp link ac 1750 v 4.
I flashed it with
Now I can not connect to it, I can not telenet into it. I have tried to reset it by holding the reset button. The only light on is the power light. If it were bricked per tp link website the wps led light would be on solid as well and it is not. I have tried to putty in to it and it can not connect. Now what?