Help on using the Raspberry Pi 3B+ as a normal router

What I am trying to achieve is to have the RPi 3B+ connected to a wall LAN port via cable to it's own LAN port as a WAN(and set to DHCP Client), and the WiFi, as WLAN(set to Static IP), is how I would be connecting to the router(no surprises, unless I get a USB-Ethernet adapter). Having them separate gives me no internet connection on the devices connected via WiFi, but if I bridge the WLAN(or LAN, as it is called in what I have) to the WAN(which is the single LAN port the Pi has), then I get an internet connection, but I lose access to the router configuration page and am unable to SSH into the router unless I disconnect the Pi from the wall LAN port and connect it directly to my laptop with IP settings set to manual. Am I doing something wrong?

Image used is the snapshot, since the stable release does not work.

I used part of this video as a reference. Time it starts at is what the config page looks like. Of course, if needed I will post pics and text files.

  • Place one PHY in WAN Firewall Zone
  • Place other PHY in LAN firewall zone
  • Make LAN a bridge with Wireless device
  • Enable masquerade on WAN
  • Permit forwarding from LAN to WAN

As long as you can configure the above, not needed.

Seem to have gotten stuck
Place one PHY in WAN/LAN Firewall Zone:image
Or is it about putting eth in WAN and wlan in LAN?

Make LAN a bridge with Wireless Device: Should I be seeing two interfaces in the interfaces screen?
image

Enable masquerade on WAN and Permit forwarding from LAN to WAN: SSH required, or can be done on LUCI?

You can do that under Network > Firewall in LuCI:

Screenshot%20from%202018-08-17%2013-21-06
Screenshot%20from%202018-08-17%2013-21-17

I'd like to ask: I keep getting 'Unsaved Changes'. How do I get the changes to be really applied?
Or should I restart with a more up-to-date snapshot for a cleaner slate to work on?
I suppose the following is what the setup should look like(whether it is saved and applied is a different thing)
Interfaces: image
I noticed that for some reason the eth0 is shown as offline, even if an Ethernet cable is plugged in.

Firewall zones: image

Scroll to the bottom of the page and click "Save and Apply"

Sometimes I get the 'Unsaved Changes' notification at the top, even after I have clicked on 'Save and Apply'.

By any chance, do you receive a BIG WARNING that the settings break something (i.e. connectivity to the GUI), with and option to APPLY ANYWAY in a RED button?

If I see the 'Applying changes' timer time out, then I do see that alert. Other than that, since I do not see the timer time out, 'Changes applied' pops up, but sometimes there are still unapplied changes.

  • Had you ever used OpenWrt on this Pi before?
  • Basically, is this a brand new installation and your first time attempting to make and save changes?

Maybe it's an issue saving to the partition.

  • Tried using the stable release, then read somewhere here that the snapshot should be used instead due to missing drivers for the 3B+.
  • Not my first time making and saving changes to the Pi, but I did reflash a snapshot build from about 2 days ago.

Current setup is as shown:
Interfaces: image
I noticed that for some reason the eth0 is shown as offline, even if an Ethernet cable is plugged in.

Firewall zones: image
Saw somewhere where the input for the WAN zone was set to accept and forward was set to reject. Still does not seem to work.

Correct...you don't have an IP address on WAN.

How do I set up the WAN part of the router? Read this post where eth0 needs to be bridged to get an IP in DHCP client mode. Should I try that out? What else am I missing?

EDIT: Seems like what I was missing was bridging WAN, as shown below:image Both WAN and LAN are now shown to be connected.

These are the settings I have for the firewall:image
Deviated a bit from what @lleachii posted in here, would like guidance on what the differences would be if possible.

I suppose I can mark this thread solved (soon)?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.