Help on OPKG Update : Failed to download

mbo2o, I reckon you must be a linux expert or close to that.

I should rename the bin file for my router to "openwrt-sysupgrade.bin", and let's suppose the bin file is stored on my "C:\Bin" folder on my hard disk as an example, how does putty identifies the path of the file to copy it to internal memory of the router?


If your using Putty on windows you also have scp command, you need to open a windows command prompt (cmd.exe) and run the scp commnd in the previous post from C:\Bin for example.

pscp -scp openwrt.bin root@

Sorry ( the screenshot below is from openSSH ) which I didn't realise was part of windows 10 until just now.


Thanks mbo2o

Now I understood, many thanks for your help and all of you.

Hopefully by night time I will have a working router repeater.

1 Like

OPKG Update : Failed to download

this is normal if your box does not access the internet -> configure your network

test with by exemple : ping

I don't know what has happened for not downloading anything, but one thing I notice, as soon as I plug my ethernet cable to my laptop internet just dies, but it doesn't always happens, tried to bridge Ethernet with Wifi, also the same doesn't do nothing.

I guess best solution is to upgrade offline to a firmware with luci embedded.

Failed to download …
This “famous” wget 4 error in opkg is just a general error from wget that says that your network settings are wrong, see wget manual. It has almost nothing to do with opkg itself.

Solution: Check your network settings and get your internet access up and running, then it should work.

ssh root root
edit etc/config/network similar to this

config interface 'lan'
option type 'bridge'
option ifname 'eth0 eth0.1 eth0.2'
option proto 'static'
option netmask ''
option ip6assign '60'
option gateway '' > my router is
option dns '
option ipaddr '' > for me i have changed with this

or test:with uci command
uci set network.lan.dns=
uci commit network

after opkg update
opkg iinstall luci

if i have a little time i can compile for you a firmware with LUCI


alright tried to copy upgrade.bin to tmp got this error, btw renamed the long name to something simple like 1.bin

scp: /root/tmp/1.bin: No space left on device

/root/tmp/1.bin is not /tmp/, the former would be on your flash, which is obviously too small to hold both the running and the new firmware, the later is in RAM (tmpfs), which should be big enough.

1 Like

test with this ( 8M ) :

LUCI and some kmods: NTFS3G , FAT32 , Relayd ...

All members,

I have finally be able to update the firmware, firstly I sad bad things about this router but not now anymore, after a massive brainstorming regarding Openwrt and reading lots of tutorials I finally get the speed I needed, used Bridge Relay between my 2 wifi frequencies (2,4 and 5), 5 as client 2,4 as Access Point, differences from my previous wifi repeater, this time I get a more stable signal, and download speeds,

Thanks to you all

Thanks for compiling this firmware for me, I will try them out, official 18.06 has some issues with this device with its MediaTek MT7620A chip, it runs very slow, when compared with stock fw, it transmits almost less 5 times slower than (10 mbits agaisn't 50 mbits) the chip in charge of 5ghz frequency is awesome, on my tests it almost equals speeds of cable interface.

Since this compilation comes from a snapshot, hopefully the issue is sorted.

Dear all,

Just found what can be the easiest way to get luci on snapshots fw.

Installed a fw with luci embedded and didn't do anything else than to connect to main router, choose SID and Password, afterwards used WinSCP to copy from the router main memory the wireless config file which is on /etc/config/wireless and network file for backup purposes.

Flashed new Snapshot FW, run WinSCP again and overwrited etc/config/wireless and network file back to the router, rebooted through Puty

Run both the instructions

opkg update
opkg install luci

And Voilá Luci Installed with no effort.

Hi all,

Recently restored 3 ubiquity "routeStation boards" to factory settings. When I run the opkg update get an network connection error.

I have Connecting my "routerStation boards" to my lap top through a cross over cable,(I hope to gain access to internet wireless through my lap top) and then connected to one of the 3 LAN ports on the router Station.
Static IPV4 on Lap top Ethernet
Default gateway IP on lap top
The settings below are from etc/config/network.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd37:5c54:f036::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 0t'

Any advise as to what settings need to change before I can connect to network.

Will I need to disable ipv6.

Thanks for the quick response.

Usually no need, it either works or can be safely ignored.

Do you have your laptop configured to share your internet connection? By default, your computer will not be setup for this. As an example, on a Mac, for example, you must turn on internet sharing and select the "from" (i.e. which interface currently has the internet connection) and the "to" (which interface will have devices that need internet access)?


If you can directly connect your routerstation's WAN port to your current router (that is, in turn, connected to the internet; instead of connecting through your computer like you're doing currently), you will find everything much easier. You can connect your computer to one of the routerstation LAN ports and you'll be able to do everything you want.

Thanks for the quick response. Hopefully I'll get it up and running, going to work on it tomorrow. I have a Vodafone router with sim card.

A post was split to a new topic: OPKG update: Signature file download failed

very simple, go to NETWORK ---> INTERFACES----> WAN6 and deactivate the hole interface, save reboot the router and the magic begins.... eureka opkg upgrade done with no errors